Control problem? - Harley Davidson Forums



Control problem?

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 01-28-2017, 09:47 AM
KDUBYA's Avatar
KDUBYA KDUBYA is offline
One Of The Regulars
Thread Starter
Join Date: Feb 2008
Location: Northfield, NH
Posts: 270
Thanks: 0
Thanked 0 Times in 0 Posts
Default Control problem?

I have a biketronics retro radio kit running an Alpine head unit. Frequently I have to move the controls several times to get it to respond.... any ideas? I have checked the connections.... I am not a fan of the way the connections are made....
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Ultra with cruise control - carb change? Laverda1200 Carburetor Related 5 01-28-2017 09:58 AM
Cruise control will not turn on!!!! Therr333 Touring Models 20 07-18-2016 01:13 PM
Aquatic Radio Issue Throttle1971 Touring Models 7 02-10-2016 02:58 PM
Scosche HDSWC1 issue UltraBra Audio Systems 2 10-29-2015 06:09 PM
Turn signal question rlchristensenmd Dyna Glide Models 16 10-23-2015 07:57 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 04:04 AM.


 
  • Ask a Question
    Get answers from community experts
What's your question?
Send