Go Back   Harley Davidson Forums > Harley Davidson Tech & Mechanical Forum > Electrical/Lighting/Alarm
Sign in using an external account
Register Forgot Password?
Search


Electrical/Lighting/Alarm Having electrical problems? Discussion on everything electrical and lighting systems.

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 02-08-2013, 06:18 PM
buddyman47 buddyman47 is offline
Hang Around
Join Date: Feb 2013
Location: Tampa
Posts: 4
Default speedometer problems

I have a 99 heritage softail with original speedo; working fine until recently when the digital display went blank and the needle went south.
I've checked everything; took sensor out of transmission and cleaned off magnetic filings etc.; still not working; replaced speedo with another original 99 and it did the same thing. (when engine starts.....display shows; but when put in gear and starting out......the digital display dies and the needle doesn't register.)

Purchased new sensor and replaced old one; Still doing the same thing.

HELP !!!!!

thanks for any suggestions.
Reply With Quote
  #2  
Old 02-08-2013, 07:59 PM
UltraNutZ's Avatar
UltraNutZ UltraNutZ is offline
Moderator
Join Date: Nov 2007
Location: Cypress, TX
Posts: 12,181
Default

is the speedo the only electrical problem you're having with the bike? If so, I believe there is a connecter under the tank for the speedo that might need to be looked at.
if you're having any other issues, I'd be looking at the fuse box and battery cables for loose or corroded connections.
__________________

"TTS FOR DUMMIES" by Mr.Wizard
"SEPST FOR DUMMIES" by Foxster
"PV Step By Step" by sportytrace
2012 FLHTK
Motor: Vee-Twin Street Port, Andrews 57H, Fullsac DX, CVO 4" Cans w/Fullsac 2.25" Power Cores, TTS, Mach2 A/C, Barnett +1, 480 Spring, ClutchWiz
Audio: Kenwood KIV-BT901, RF 3sixty.3 DSP, (2) SoundStream TN4.900D, Biketronics (4) 7.1", (2) 6.5", (2) 6x9"
Reply With Quote
  #3  
Old 10-09-2013, 07:09 PM
willyp's Avatar
willyp willyp is offline
Road Master
Join Date: Apr 2007
Location: NC
Posts: 860
Default

I have a 99 softail. speedo/odometer problems.....same as yours so I worked on the speedo yesterday and today...all the wires checked out so I narrowed it down to speedo itself or the speed sensor. shop manual uses a speedometer tester part number HD-41354. I figured this would be nice to diagnose my problem. called the dealer to see if they had this test set, they told me I had to bring my bike in because they don't work on parts off the bike. I asked if I brought in a wheel would they mount and balance a tire and they said sure? WTF? Thanks for nothing!

anyway now I think it may be the voltage regulator. had me puzzled. didn't realize there was a diagnostic mode on the speedo which showed the fault code of d08 which means over voltage. speedo and odometer work fine when sitting idle but as I accelerate the speedo goes to 0 and the odometer blanks out. I had a multi meter on the battery while the bike was off....12 volts. at idle, 14 volts and as I increase the throttle the voltage jumps up to 17 volts and thats when the speedo fails. should stay at 14 correct? I am thinking voltage regulator. the dealer has one for $122, I went outside and checked Drag Specialties on my phone...$53.99. went back inside and told the parts guys no thanks I found it for cheaper.....he said I would still have to pay shipping..HAHA! did you ever figure out the problem? looking for some feedback before I pull the trigger on any new parts. thanks.
__________________


The price of cool aint cheap
Reply With Quote
Old 10-09-2013, 07:09 PM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help please 02 RK TSAVO Touring Models 3 04-23-2014 03:54 PM
Lost speedo then digital odo, bang bang stop. dynaglyder Ignition/Tuner/ECM/Fuel Injection 8 02-07-2014 05:01 PM
speedometer problems buddyman47 Testing Area 1 02-09-2013 06:58 AM
Sortster speedo stuck on zero Toolbndr Ignition/Tuner/ECM/Fuel Injection 3 12-09-2012 07:53 PM
Electronic Speedo Problems on 97 Springer? PanHeadRich Evo Classic Models 6 08-28-2012 06:38 PM



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 07:12 PM.


Internet Brands, Inc.