Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Evo Classic Models
Sign in using an external account
Register Forgot Password?
Search


Evo Classic Models All Evo Models
Sponsored by: J&M Motorcycle Audio

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 09-05-2009, 08:43 AM
dog155's Avatar
dog155 dog155 is offline
Extreme HDF Member
Join Date: Nov 2006
Location: Windham,Maine
Posts: 12,764
Default 120" Ultima Problems?

A friend just asked me about his 120" with approx 1K on the clock.When his reaches operating temps it starts losing power,and making a funny sound.I know it is not much to go on,I have not seen it.Just trying to get an idea of what we could look for.He says the motor only has 1 vent hose,that by itself does not sound right.Grasping for straws!!!
__________________
2006 RK 155" R&R TwinCam
2000 Boss Hoss 427" SBC
Reply With Quote
  #2  
Old 09-05-2009, 09:59 PM
miacycles's Avatar
miacycles miacycles is offline
Elite HDF Member
Join Date: Sep 2007
Location: Bluffton, South Carolina
Posts: 4,463
Default

What chassis is it in? "Funny sound" is a little vague, Is it a grinding, a squeaking or what. How is the oil pressure? Where does the noise appear to be comming from? How is his compression? Take the plugs ou and torn the motor over by hand, how does it feel? See if you can get a little more input.
__________________
Marines may guard the gates of heaven
A job they may do well !!
But it takes the 82nd Airborne
To guard the gates of hell !!

If you find yourself in a fair fight
Your tactics suck !!!!!!!
Reply With Quote
  #3  
Old 09-06-2009, 04:39 AM
dog155's Avatar
dog155 dog155 is offline
Extreme HDF Member
Join Date: Nov 2006
Location: Windham,Maine
Posts: 12,764
Default

Have to drive 1 1/2 hrs to his house to see motor.He says the plugs look great,oil pressure was normal,noise seems to be coming from front cylinder.other than that he is afraid to go any deeper.
__________________
2006 RK 155" R&R TwinCam
2000 Boss Hoss 427" SBC
Reply With Quote
  #4  
Old 09-07-2009, 08:31 AM
miacycles's Avatar
miacycles miacycles is offline
Elite HDF Member
Join Date: Sep 2007
Location: Bluffton, South Carolina
Posts: 4,463
Default

Quote:
Originally Posted by dog155 View Post
Have to drive 1 1/2 hrs to his house to see motor.He says the plugs look great,oil pressure was normal,noise seems to be coming from front cylinder.other than that he is afraid to go any deeper.
Where is he located??
__________________
Marines may guard the gates of heaven
A job they may do well !!
But it takes the 82nd Airborne
To guard the gates of hell !!

If you find yourself in a fair fight
Your tactics suck !!!!!!!
Reply With Quote
  #5  
Old 09-08-2009, 06:47 AM
dog155's Avatar
dog155 dog155 is offline
Extreme HDF Member
Join Date: Nov 2006
Location: Windham,Maine
Posts: 12,764
Default

Vassalboro.
__________________
2006 RK 155" R&R TwinCam
2000 Boss Hoss 427" SBC
Reply With Quote
  #6  
Old 09-08-2009, 07:52 AM
miacycles's Avatar
miacycles miacycles is offline
Elite HDF Member
Join Date: Sep 2007
Location: Bluffton, South Carolina
Posts: 4,463
Default

Is that in Maine??
__________________
Marines may guard the gates of heaven
A job they may do well !!
But it takes the 82nd Airborne
To guard the gates of hell !!

If you find yourself in a fair fight
Your tactics suck !!!!!!!
Reply With Quote
  #7  
Old 09-08-2009, 07:55 AM
miacycles's Avatar
miacycles miacycles is offline
Elite HDF Member
Join Date: Sep 2007
Location: Bluffton, South Carolina
Posts: 4,463
Default

Could be a broken ring or maybe a wrist pin. He may have gotten it too hot on initial break in and scored a cylinder. Take a look in the cylinder with a light and see if you can see anything. If not maybe something in the rocker boxes. Hope this helps.
__________________
Marines may guard the gates of heaven
A job they may do well !!
But it takes the 82nd Airborne
To guard the gates of hell !!

If you find yourself in a fair fight
Your tactics suck !!!!!!!
Reply With Quote
  #8  
Old 09-09-2009, 06:51 AM
dog155's Avatar
dog155 dog155 is offline
Extreme HDF Member
Join Date: Nov 2006
Location: Windham,Maine
Posts: 12,764
Default

Vassalboro,Maine is above Augusta.Talking to my friend,he says letting the bike set a very short time it starts and runs great.When it gets hot it starts the problem over again.This problem he is having just started happening.It sounds to me without physically seeing,hearing the motor,like maybe the pistons are starting to seaze when it gets hot.Unless I hear otherwize a topend teardown is in order.
__________________
2006 RK 155" R&R TwinCam
2000 Boss Hoss 427" SBC
Reply With Quote
  #9  
Old 09-09-2009, 07:12 AM
choppit choppit is offline
Hang Around
Join Date: Sep 2008
Location: North Carolina
Posts: 2
Default

Piston slap!!! The 120" Ultima is notorious for piston slap and it usually occurs between 1000 and 3000K. Check the compression and check the oil. I'm sure there will be metal flaked oil.
Reply With Quote
Old 09-09-2009, 07:12 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New cam install spacer size? MichiganRider Touring Models 6 12-31-2011 03:47 AM
Welding the front motor mount on a 120R PHA-Q General Harley Davidson Chat 16 12-01-2011 05:29 PM
120R Softail? TORQUEY General Harley Davidson Chat 5 10-30-2011 09:24 AM
Big Boyz head porting dyno hydrolock43 Touring Models 3 07-08-2011 07:40 AM
Grab Bar USA1HD1 Touring Models 0 04-15-2011 09:56 PM


Tags
120, 124, break, engine, harley, hdforums, motor, noise, oiling, piston, problem, problems, set, touring, ulitma, ultima


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 02:59 PM.


Internet Brands, Inc.