Go Back   Harley Davidson Forums > General Harley Davidson Forums > General Harley Davidson Chat
Sign in using an external account
Register Forgot Password?
Search

General Harley Davidson Chat Forum to discuss general Harley Davidson issues, topics, and experiences.
Sponsored by: J&P Cycles

Welcome to HDForums.com!

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 06-25-2011, 07:46 PM
jherm0358 jherm0358 is offline
Hang Around
Join Date: Jun 2011
Location: Florida
Posts: 3
Default HD CB Radio Problems!

I have a 1998 HD Ultra Clasic and I am having trouble getting the cb to work. My bike has the 2 rockers on the gas tank. One for intercom and the other for cb. During a ride to Key West with a group I was directed to tune into channel 3 so we could communicate while riding. I did not have my microphone with me to plug into the jack. I was told that I didn't need it to monitor the traffic. But, when I push the toggle to on, the light does illuminate, but the cb does not appear in the radio display. Even when I push the toggle to set-up, I still do not get any response from the radio as to being in cb mode. My antenna is connected, as far as I know, since I have never disconnected anything under the fairing. My intercom does work when plugged in to both front and back. Just tossing that out for information. I've read the owners manual over and over trying to figure out if I'm the one doing something wrong. Any ideas?
Reply With Quote
  #2  
Old 06-25-2011, 08:01 PM
badwhine's Avatar
badwhine badwhine is offline
Outstanding HDF Member
Join Date: Aug 2007
Location: Earth
Posts: 2,872
Default

Is the nut on the button tight?
__________________
If loud pipes save lives, imagine what learning to ride could do.
Reply With Quote
  #3  
Old 06-25-2011, 08:15 PM
K Melancon's Avatar
K Melancon K Melancon is online now
Road Captain
Join Date: Mar 2011
Location: Deep South, Louisiana
Posts: 735
Default

Play with your switches, you just have to figure its positions.
Reply With Quote
  #4  
Old 06-25-2011, 09:06 PM
jherm0358 jherm0358 is offline
Hang Around
Join Date: Jun 2011
Location: Florida
Posts: 3
Default CB Radio Problems

I don't know what nut to check to see if it is tight.

I have pushed the buttons in all the combinations I can possibly do. At least I think I have.

I was at Destination Daytona this mornign trying to pick their brains too. They were unsure of what to suggest, except to bring it in and let them play with it.

I do appreciate your responses though.
Reply With Quote
  #5  
Old 12-16-2011, 08:06 PM
jherm0358 jherm0358 is offline
Hang Around
Join Date: Jun 2011
Location: Florida
Posts: 3
Default Touring Radio Problems

I had my radio repaired at Radio Sound ($200) - They replaced the faceplate because they said it was cracked ($50) - I re-installed it only to find the cb still does not work. A tech at Radio Sound told me how to put the systme in diagnostic mode - I test of the codes showed no connection between the radio and the cb switch - So, I buy a new switch ($117) and installed the new switch assembly - The new switch works no better or just as well as the old - So, does anybody have any suggestions? I still don't know where the nut is to tighten as another post suggested. It used to work years ago when I turned it on once. I'm running out of ideas.
Reply With Quote
  #6  
Old 12-17-2011, 10:31 AM
98Ultra's Avatar
98Ultra 98Ultra is offline
Road Master
Join Date: Apr 2008
Location: S.E. NC
Posts: 948
Default

Still the stock radio? If so, can't help. My 98 had a newer radio (CD Player) and the switches no longer had any effect, it was done on the radio.
__________________
It all started with that 74 Sportster.
Then came the 82 FXRS, 99 FLSTS,(yamaha 650 v-star), 74 IronHead in a 78 Frame, 98 FLHTCUI, 73 IronHead, 08 FLHTCUI, 09 FLHTCUI, 13 FLHTC
2013 EG Classic and a 1973 IronHead to keep me calm now.
Reply With Quote
Old 12-17-2011, 10:31 AM
 
 
 
P
Reply

Tags
2012, 32, cb, channels, davidson, harley, harleydavidson, industry, powered, problems, radio, shooting, trouble, troubleshooting, vbulletin, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump

Advertising
Featured Sponsors
Vendor Directory
Sponsors
All times are GMT -5. The time now is 08:02 PM.

Internet Brands, Inc.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2

Admin, Emails & Contact Details