Go Back   Harley Davidson Forums > Harley Davidson Tech & Mechanical Forum > Ignition/Tuner/ECM/Fuel Injection
Sign in using an external account
Register Forgot Password?
Search


Ignition/Tuner/ECM/Fuel Injection Need advice on ignition issues? Questions about a tuner? Have questions about a EFI calibration or Fuel Injection? Tips on Engine Diagnostics, how to get codes, and what they mean. Find your answers here.
Sponsored by: Cardo Systems

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 07-05-2007, 02:16 PM
ridgeruner ridgeruner is offline
Join Date: Jul 2007
Location:
Posts: 2
Default IGNITION MODULE PROBLEMS

I AM HAVING PROBLEMS WITH MY IGNITON MODULE. I HAVE A 1996 FLHT STOCK MOTOR AND TRANS. I HAVE ADDED A S&S CARB AND THATS ALL THE UP GRADES TO THE ENGINE. "BUT" I HAVE BLOWN TWO MODULES IN THE LAST 6 MONTHS OR SO. ANY BODY ELSE HAD THIS PROBLEM.

I HAVE ORDER A ULTIMA SINGLE FIRE ING. SYSTEM TO REPLACE IT JUST THOUGHT I WOULD ASK FIRST!
__________________
PUTT SAFE.
Reply With Quote
Old 07-05-2007, 02:16 PM
 
 
 
P
Reply


Tags
53645, davidson, engine, evo, fire, harley, igintion, ignition, module, moduler, problem, problems, single, system, troubleshooting, ultima


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 07:42 AM.


Internet Brands, Inc.