Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Sportster Models
Sign in using an external account
Register Forgot Password?
Search


Sportster Models 883, 883 Custom, 1200 Custom, 883L, 1200L, 1200S, 1200 Roadster, XR1200, and the Nightster.
Sponsored by: Rush Racing Products

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 11-17-2009, 07:01 PM
Badass67stang's Avatar
Badass67stang Badass67stang is offline
Prospect
Join Date: Jul 2009
Location: Marcus Hook Pa
Posts: 248
Mental 2
Default sportster shut off going 50

3 times over my past 2 rides my sportster has shut off while riding all 3 times i was going approx 50 in 5th gear and gunned the gas and the bike shuts off just for a split second the lil engine on the speedo lit up and the bike starts right back up because its still in gear.


any ideas?
Reply With Quote
  #2  
Old 11-17-2009, 07:05 PM
Norecoil Norecoil is offline
Hang Around
Join Date: Nov 2009
Location: USA
Posts: 27
Default

How about the on/off switch? Do you think the contacts might be breaking down and cutting the bike off during the high speed vibration? I would also check all my wiring to make sure nothing is loose. Might start with the Bat conns first. HTH
Reply With Quote
  #3  
Old 11-17-2009, 07:28 PM
cm6 cm6 is offline
Hang Around
Join Date: Jun 2009
Posts: 2
Default

Same problem here, doing 70 bike backfired really loud, shut off and would only crank after that. After 30 minutes of fiddling around got it to start for a few seconds then died. 1 hour later got it to run but it was horrible. One cylinder strong, rear one was intermittent. 2 hours later started back up after cleaning plugs, ran like nothing ever happenned. Long story short it was my ignition module. Mine is in my nose cone, yours should be to, i believe but not sure. Engine gets warm, ignition module fails, engine cools down, module works. Just to be safe check your coil first. It is alot easier to replace.
Reply With Quote
  #4  
Old 11-17-2009, 07:29 PM
cHarley's Avatar
cHarley cHarley is offline
Old Fart
Join Date: Feb 2007
Location: Boynton Beach, FloriDuh
Posts: 15,149
Default

STEP ONE: Read the DIY sticky thread at the top of this section for instructions on how to read the diagnostic codes. Then, report back on what you find.
__________________
IF YOU CAN'T RIDE IT OR TAKE IT TO BED, IT AIN'T WORTH HAVING


Light travels faster than sound. This is why some people appear bright until you hear them speak.
04 1200C - Hammer 1250 - Smash Heads - .560 Cams - Supertrapp - Hurricane Flow A/C - TC88A Ignition

Reply With Quote
  #5  
Old 11-17-2009, 08:41 PM
Nonstop Nonstop is offline
Senior Rider
Join Date: Mar 2008
Location: Where we love our Beaver.
Posts: 394
Default

Loose negative battery connection.
__________________

2007 Olive/Black Nightster
RK Air Shocks, 2"lowering kit.
RSD ShortStacks.
Mustang Tripper
V&H SideShots, V&H FuelPak.
SE Heavy Breather.
Reply With Quote
  #6  
Old 11-17-2009, 10:16 PM
NI-STER NI-STER is offline
Prospect
Join Date: Sep 2009
Location: Alberta, Canada
Posts: 152
Default

Loose battery connection. Me thinks Nonstop and I have had the same issue with the N.
Reply With Quote
  #7  
Old 11-18-2009, 05:01 AM
bmxatv's Avatar
bmxatv bmxatv is offline
Elite HDF Member
Join Date: Jul 2008
Location: Up your block and down your alley
Posts: 4,428
Tweet This! @2wheelobsessed
Default

this **** happen to me and turned out it was only running on one cylinder because this connection between the jugs came loose.
Attached Thumbnails
sportster shut off going 50-2009_08240005.jpg  
__________________
ForeverTwoWheels

Last edited by bmxatv; 11-18-2009 at 05:05 AM..
Reply With Quote
  #8  
Old 11-18-2009, 10:25 AM
dlhike's Avatar
dlhike dlhike is offline
Prospect
Join Date: Jul 2009
Location: Bellevue, NE
Posts: 207
Default EFI relay?

I had this problem with my 07 roadster when I first bought it,,,sometimes it would go days no issue then it would happen 1, 2 or 3 times on a ride. Took it in and it ended up being the fuel injector relay $20 fix...just another possibilty...
__________________
07 XL1200R
U.S.M.C 79 - 82
Ride what U want, where U want, how U want and wear what U want while doin it...if they can't take a joke - kill em...
Reply With Quote
  #9  
Old 11-18-2009, 12:31 PM
Badass67stang's Avatar
Badass67stang Badass67stang is offline
Prospect
Join Date: Jul 2009
Location: Marcus Hook Pa
Posts: 248
Mental 2
Default

my sportsters a carbed 05 i ran the codes before posting the thread and it said none,could jetting make it do that? my battery does struggle sometimes to start the bike since its been cold ill check the cables later to see if there loose.
Reply With Quote
  #10  
Old 11-18-2009, 12:55 PM
Bulpitt's Avatar
Bulpitt Bulpitt is offline
One Of The Regulars
Join Date: Dec 2008
Location: Mar Vista, Ca
Posts: 199
Default

I had this problem for a short time & it was a relay for me also...
__________________
Always a work in progess
Reply With Quote
Old 11-18-2009, 12:55 PM
 
 
 
P
Reply


Tags
1200, 2000, 2005, bike, custom, davidson, engine, harley, hot, polaris, riding, running, shuts, speedometer, sportster


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 01:19 PM.


Internet Brands, Inc.