Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Sportster Models
Sign in using an external account
Register Forgot Password?
Search


Sportster Models 883, 883 Custom, 1200 Custom, 883L, 1200L, 1200S, 1200 Roadster, XR1200, and the Nightster.
Sponsored by: Rush Racing Products

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 06-30-2010, 02:17 PM
Rahul S Deshpande Rahul S Deshpande is offline
Hang Around
Join Date: Jun 2010
Posts: 3
Default Engine turns but won't start

Hi - can anyone help - Sportster 883 Custom 2008 (with EFI) - the battery ran out 'coz the bike wasn't started for 2 months, and I've tried jump-starting the bike with my car battery - the engine turns, but the bike won't start. I can't seem to hear the Fuel Pump "purr" when I turn on the Ignition. The Fuel Pump 15A fuse is ok. What can I check, and how do I do it ? I'm in India, where there's no dealer/service available. And yes, there's plenty of fuel in the tank + the spak plugs are - well - sparking !

PLEASE HELP !!!
Reply With Quote
  #2  
Old 06-30-2010, 02:33 PM
veritas.archangel's Avatar
veritas.archangel veritas.archangel is offline
Road Master
Join Date: Dec 2009
Location: Allyn, WA
Posts: 1,199
Default

I'd say try getting the battery charged properly, then try again.
__________________

'06 Street Bob
'76 Triumph Bonneville
'84 Honda VF700S Sabre
'85 Yamaha FJ600
'86 Honda VFR750F
'07 Honda CBR1000RR Repsol
Reply With Quote
  #3  
Old 06-30-2010, 02:51 PM
Rahul S Deshpande Rahul S Deshpande is offline
Hang Around
Join Date: Jun 2010
Posts: 3
Default

....thanks v.a. - will do - am a bit surprised, coz it was running fine when i last rode it, and i've done only 80 miles on the Odo - there's also a solenoid "chatter" sometimes when I hit the starter button; at other times the engine turns over just fine (but doesn't run!!)
Reply With Quote
  #4  
Old 06-30-2010, 02:51 PM
Gpsjr10's Avatar
Gpsjr10 Gpsjr10 is offline
Outstanding HDF Member
Join Date: Jun 2007
Location: Elyria, OH
Posts: 2,533
Default

Make sure you check the fusebox for corossion, also swap the relays around and see if the fuel pump runs. Could be bad relay.
__________________
08 Nightster- Bassani side by side drag pipes- Stage 1


If you ask a Yes/No question,
Expect the answer to be Yes or No.
Reply With Quote
  #5  
Old 06-30-2010, 02:57 PM
Rahul S Deshpande Rahul S Deshpande is offline
Hang Around
Join Date: Jun 2010
Posts: 3
Default

Ah, OK - I suppose you mean the Starter and System relays ? Thanks, guys.
Reply With Quote
  #6  
Old 06-30-2010, 09:14 PM
shiftharder's Avatar
shiftharder shiftharder is offline
Road Master
Join Date: Jun 2010
Posts: 913
Default

Happened to me twice - both times it was the relay - I now carry a spare relay in my pouch - had to be towed both times for a 15$ relay.
__________________
The Harley Motto: If it breaks, make it bigger. If it sticks out, chrome it.

2008 1200 Custom/V&H Slip-On`s
Flat handle Bars
Relocated Turn Signals/Black-out Turn Signals
Nightrider X14iED
Reply With Quote
  #7  
Old 06-30-2010, 11:42 PM
Blue Cross Bones's Avatar
Blue Cross Bones Blue Cross Bones is offline
Prospect
Join Date: Jun 2010
Posts: 111
Default

Can using the car to start the motorcycle damage any type of electrical wiring?
Reply With Quote
  #8  
Old 07-01-2010, 08:42 AM
wilburz's Avatar
wilburz wilburz is offline
Road Warrior
Join Date: Jun 2007
Location: Royal Palm Beach, FL
Posts: 1,467
Default

i think its ok to jump a bike with a car but the car is not supposed to be running at the time. too many amps.
__________________
2007 Sportster 1200C
http://www.hdforums.com/upfiles/34146/A5F3AF3AAB8D4B2F8DE1BA13FFEE7388.jpg

Happiness is a belt fed weapon!
Reply With Quote
  #9  
Old 07-03-2010, 06:57 AM
rsd.883 rsd.883 is offline
Hang Around
Join Date: Jul 2010
Location: New Delhi, India
Posts: 1
Send a message via Skype™ to rsd.883
Default

Quote:
Originally Posted by shiftharder View Post
Happened to me twice - both times it was the relay - I now carry a spare relay in my pouch - had to be towed both times for a 15$ relay.
Update : tried starting after 2 months; battery was low - got it recharged and reconnected. Now the engine turns over sometimes, and sometime there's a loud "chattering" sound (Owner's manual calls it "solenoid chatter". But even when the engine turns over every 2nd/3rd try, the engine doesn't fire. Model 2008 Sportster XL883 Custom - I'm in India, with nearest dealer 2,000 miles away, so have to do a DIY on this !!

PS - I could earlier hear the fuel pump "purr" when I switched on the ignition, now there's just a "click"-on and "click"-off like a relay kicking in and out, but no "purr"ing sound. Checked the Fuel Pump 15A fuse (even replaced it), no luck; switched around the System and Starter relay blocks, still no luck. How can I check if the Fuel Pump (which I suspect) is busted ? HEEEEEELP !!!!
Reply With Quote
  #10  
Old 07-03-2010, 08:21 AM
99superglide 99superglide is offline
Senior Rider
Join Date: Mar 2007
Location:
Posts: 467
Default

I looked through my service manual about this but couldn't seem to find exact info on testing the fuel pump. So here's what I'd do.. You should definetely hear the fuel pump purr for a few seconds when the key is turned on and the run switch on. If not I would check current going to the fuel pump fuse when you hit the run button with the key on with a voltage meter. The fuel pump fuse is the small 15 amp fuse at the top left of the fuse block. I dont know what the voltage would be but you should get a reading on the meter. I'm assuming you would have power to this fuse which then would feed current to the relay and then to the fuel pump. If you have power to the fuse then the next thing I'd check is the relay. I'll look through the book a bit more and see what I can find for info on testing the relays.
Reply With Quote
Old 07-03-2010, 08:21 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please Help! Bike dont start skeetskeet Ignition/Tuner/ECM/Fuel Injection 2 03-04-2014 12:07 AM
help..... 2001 ultra classic won't start Eddie's ride Touring Models 13 10-04-2013 07:27 PM
The Bike won't start,2007 sportster, missing something giacimo Sportster Models 19 02-17-2013 02:29 PM
Please Help! 2010 Wide Glide won't start DBuggy Dyna Glide Models 4 02-20-2012 10:43 AM
Battery Question midav Sportster Models 6 03-11-2008 09:30 AM


Tags
1200, 2008, doesnt, engine, fire, fuel, harley, injected, pump, sportster, start, starter, turns, wont, work


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 10:22 PM.


Internet Brands, Inc.