Harley Davidson Forums

Harley Davidson Forums (http://www.hdforums.com/forum/)
-   Sportster Models (http://www.hdforums.com/forum/sportster-models-10/)
-   -   Electrical issues, starter switch or relay? (http://www.hdforums.com/forum/sportster-models/638282-electrical-issues-starter-switch-or-relay.html)

30Bones 05-12-2011 03:52 PM

Quote:

Originally Posted by Booey424 (Post 8310483)
I had the same problem. Mine was fixed by replacing the selenoid fuse. But you said the fuses were fine. So I am not helping, I guess

Which fuse in particular? I replaced both starter and system relay, and all 15amp fuses were all good. If I am missing one someplace other than the fuse box, I am open to other things to look for if my previous thought is incorrect (which I am sure it is) :icon_dunce:

30Bones 05-17-2011 01:30 PM

Update

Took it in at lunch. Technician was pretty cool, brought out a laptop and plugged it in on the trailer. Had some codes dealing with the stupid security system, still nothing after he reset those. So he said it may be the Turn Signal Control Module, which runs with the security system IIRC. So I let em have the bike. Called n left a message 15 min later that that was it, ordering it and it will be fixed next week. Need to call back and see if I can replaced it myself to save $$ or if it needs puter work after. Also said if he can delete the security system to DO IT. Silly option IMO anyway

EAGLEKNOLL 03-27-2012 03:56 PM

Stater relay
 
The starter ralay seems to be the problem I own a 2008 Nightster and the same thing happens to me. I washed it a couple of days ago and she started doing the same thing had to replace the battery last August for the same reason. I ordered a new relay from denniskirk.com at the tune of $12.99 and $7.99 shipping and handling, and while I wait for my new relay to arrive I have been yanking the relay out of it's socket when it sits and put it back in when I am going to ride it for the past two days I have done this and the bike starts up every time.

cHarley 03-27-2012 05:25 PM

Quote:

Originally Posted by EAGLEKNOLL (Post 9583091)
The starter ralay seems to be the problem I own a 2008 Nightster and the same thing happens to me. I washed it a couple of days ago and she started doing the same thing had to replace the battery last August for the same reason. I ordered a new relay from denniskirk.com at the tune of $12.99 and $7.99 shipping and handling, and while I wait for my new relay to arrive I have been yanking the relay out of it's socket when it sits and put it back in when I am going to ride it for the past two days I have done this and the bike starts up every time.


The relays in the Sporty are very common automotive relays, you can buy them at any auto parts store for less than $10.00. The last one I bought at NAPA was ~$7.00.

The NAPA p/n is AR614

EAGLEKNOLL 03-28-2012 11:08 AM

Deconstructing old relay
 
I plan on deconstructing my old relay when I get my new and if the new actually solves the problem and testing the diode. I have read that a blown clamping diode will allow current to go to ground dischaging the battery.

jeffreydsilver 03-28-2012 11:27 AM

There You Go!
 
Quote:

Originally Posted by blackie (Post 8307974)
ok your gonna have to check the smaller gauge (starter activate) wire going to the stater itself with a 12v test light. once u got the test light grounded and touching the start wire turn the key on and press the start button. if the testlight lights up then your starter is bad. if the testlight does nothing then double check the starter fuse and check the neutral saftey switch.. good luck.

Cheap $5.00 test light + 10 minutes tops = job done right first time!

You beat me to the post!!

BTW - you can remove the security system by replacing the turn signal module with a standard one.

baustchs73 05-05-2013 12:32 AM

Ok IM new to this so bear with me (relay or switch)
 
I have a xl883n 2010, I am trying to troubleshot why it won't start. I turn the key on and lights come on however no fuel pump prime and when I hit the start I get a loud click. Its coming from the fuse box, its the starter relay.

Question, how do I test to see if it is the starter relay? and where can I get one?

Help...

cHarley 05-05-2013 06:39 AM

Quote:

Originally Posted by baustchs73 (Post 11253848)
I have a xl883n 2010, I am trying to troubleshot why it won't start. I turn the key on and lights come on however no fuel pump prime and when I hit the start I get a loud click. Its coming from the fuse box, its the starter relay.

Question, how do I test to see if it is the starter relay? and where can I get one?

Help...

Try reading the post that's 3 posts above yours.

lo-rider 05-05-2013 11:39 AM

Buy the diagnostics manual.


All times are GMT -5. The time now is 05:18 PM.