Friends sporty wont hold battery charge - Harley Davidson Forums

Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Sportster Models
Log In 

Sportster Models 883, 883 Custom, 1200 Custom, 883L, 1200L, 1200S, 1200 Roadster, XR1200, and the Nightster.
Sponsored by: Rush Racing Products

Friends sporty wont hold battery charge

Thread Tools Search this Thread
Old 12-05-2006, 11:25 PM
Boogity_Boy Boogity_Boy is offline
New Member
Join Date: Mar 2006
Posts: 77
Default Friends sporty wont hold battery charge

My friend has a 1997 sportster 1200 but the battery will not hold charge. She replaced the battery and still wont hold charge. So if anyone has had this problem or might know what this problem could be your ideas would be appreciated.
As long as people do what I say, My communication skills are just fine!
Reply With Quote
Old 12-05-2006, 11:44 PM
ronn39's Avatar
ronn39 ronn39 is offline
Road Master
Join Date: Nov 2005
Location: Leesburg, Florida
Posts: 980
Default RE: Friends sporty wont hold battery charge

I guess I'd put an amp meter in line with the battery and first see if the alternator is charging the batter when running, and second to see if something's bleeding off the charge when it's not running.
04 XL1200C (Still fun to ride)
02 Road King (Gone but not forgotten)
11 Road Glide Ultra
Reply With Quote
Old 12-06-2006, 12:02 AM
drum412 drum412 is offline
Road Captain
Join Date: Jul 2006
Posts: 656
Default RE: Friends sporty wont hold battery charge

like ronn39 said. You'll have to figure wether the bike isn't charging while running, or leaking current while bike is off. Easiest thing to do is start off with a charged battery, so use a charger first, or barow another battery you know has a full charge on it, and use a voltmeter with the bike running and measure voltage between positive and negative terminals, while running you should be about 14 volts or so, if it read 12 volts or lower, then theres something wrong with the charging system. If you are getting around 14 volts while running, then the problem must be drainage while the bike is off. Solutions: If charging system is at fault, get yourself a manual, it'll give you all the troubleshooting steps to test the entire electrical system. If its drainage while the bike is can be even more messy, most likelly something is grounding somewhere allowing for a complete circuit, best way to go is follow your positive battery terminal through all the components it is directly connected to first, like ignition switch's, solenoids whatever. And once again a manual can help with testing various components. Also while your at it, clean up as many of the electrical terminals as you can. Good luck.
94' 1250 Hugger
stretched tank
andrews n4 cams
cycle shack slip-ons
mustang vintage solo
Mikuni HSR42
Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
TecMate State Of Charge Monitor JustMike General Harley Davidson Chat 1 11-08-2015 03:58 PM
90 evo weak spark j440 Evo Classic Models 4 05-08-2015 10:23 AM
Dyna battery in a sportster?? Jamesbarber1989 Sportster Models 4 11-07-2014 04:34 PM
Time for a Battery Rude1 Electrical/Lighting/Alarm 2 03-26-2014 04:28 PM
Road glide charging problem SloPoke57 Touring Models 8 09-26-2012 08:26 PM

1997, 883, battery, charge, davidson, driving, evo, harley, hold, recharge, running, sportster, starts, wont, wrong

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

All times are GMT -5. The time now is 10:19 PM.