Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search


Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 04-13-2010, 07:26 PM
jlbullet57 jlbullet57 is offline
Hang Around
Join Date: Apr 2010
Posts: 1
Default roadglide shuts off when riding

hi,anybody had this problem.2007 roadglide every so often it just shuts off while riding, like i hit kill switch thanks
Reply With Quote
  #2  
Old 04-13-2010, 08:21 PM
Kilo6 Kilo6 is offline
Senior Rider
Join Date: Apr 2007
Location: Alexandria, Va
Posts: 357
Default

Nope. Do a thorough search and you may come up with something. Good luck.
__________________
07 Road Glide
Reply With Quote
  #3  
Old 04-14-2010, 11:05 AM
DMcBiker's Avatar
DMcBiker DMcBiker is offline
One Of The Regulars
Join Date: Sep 2008
Location: NB, Canada
Posts: 233
Default

I feel your pain; my 05 FLHT has done the same thing to me twice in past year and a half. No reason for the shut down, just cruising along a smooth road and it died. I pulled off to the side of the road, turned off the ignition, and then turned it back on hit the started and she fired rate up. Iíve looked for loose wires, bad fuses, trouble codes, you name it, and I canít find anything wrong. If you find a solution, please let me know.
__________________
2012 RGU, Madstad 16" Shield
De-Catted Head Pipe, 4" Rinehart's
Reply With Quote
  #4  
Old 04-14-2010, 02:20 PM
sfchief sfchief is offline
Senior Rider
Join Date: Mar 2009
Location: Idaho
Posts: 301
Default

Have a buddy who had the same thing on his 02 Ultra. His seemed to do it when it was hot. He eventually solved it by buying an 09 Ultra. As soon as he did, he read a post on another site (don't know which one) that claimed a similar problem was caused by poor crimps on the wires leading to the 40 amp breaker that allowed corrosion to form. Might be worth looking in to. Good luck.
__________________
96 Sportster Sport (sold)
03 Road Glide (sold)
09 Road Glide
Reply With Quote
  #5  
Old 04-14-2010, 03:57 PM
badblue's Avatar
badblue badblue is offline
Prospect
Join Date: May 2008
Location: Colorado Springs
Posts: 128
Default

Had this happen on my '07 SG, once while in a tight turn, no fun. Took it in and they said the map was wrong and remapped it for free. That was about 15,000 or so miles ago and have not had an issue since.
__________________
07 flhx
Reply With Quote
  #6  
Old 04-14-2010, 04:08 PM
dawg's Avatar
dawg dawg is offline
Club Member
Join Date: Jun 2006
Location: Vermont
Posts: 20,317
Default

When it happens, try wiggling the ignition switch **** and see if it responds. That happened to me and that was the issue. Replaced the ignition switch and all was well. Some have had the contacts affected by the heat.
__________________
'08 105th anniversary Ultra
http://www.vtroaddawgsmc.org/
Reply With Quote
  #7  
Old 06-11-2010, 09:10 PM
ScrapDog55 ScrapDog55 is offline
Hang Around
Join Date: Aug 2007
Posts: 15
Default

This should be more of a common problem out there because didn't HD have a service bulliton on the 05 - 07 key switch shorting out telling the bike to shut down? Only on the street and electra glide type locking key switches.
Reply With Quote
  #8  
Old 06-11-2010, 09:35 PM
fripple's Avatar
fripple fripple is offline
Road Warrior
Join Date: Feb 2006
Location: down south
Posts: 1,700
Default

Mine did that and it turned out to be a loose connection at the battery. Not a good thing when it dies in Dallas traffic.
__________________
2009 FLTR, 96", SE-204, D&D Fat Cat 92 HP / 109 TQ (SOLD)
It's a Fat Cat (2-1, singular, uno, one), so why do you say Fat Cats?
Reply With Quote
  #9  
Old 06-12-2010, 12:22 AM
jkrahn jkrahn is offline
One Of The Regulars
Join Date: May 2010
Location: Winkler MB. Can.
Posts: 122
Default

My 99 EG did this too as i would slow down/use the brakes, seemed to be connected with washing it, I've been more carefull with the hose and have not had trouble since; I should probably put dielectric grease in all the electrical connectors.
Reply With Quote
  #10  
Old 06-12-2010, 01:58 AM
Avmech97's Avatar
Avmech97 Avmech97 is offline
Road Master
Join Date: Dec 2007
Location: Tellico Plains, Tenn.
Posts: 878
Default

Had this happen on my 2000RG and one item I replaced was the ignition switch. That was no help as it would still shut off like that. Cycling the ignition switch would restart the bike. I found the problem by using a digital multimeter with a tone function. The kill switch would briefly stutter or break contact when cycling the kill switch which is all it takes to shut the engine off. I put a new starter button/kill switch assembly on the bike and have had no issues since with the bike shutting off while on the road. I guess the switch was worn enough for the swith to break contact from the engine vibes. DMcBiker may want to try the same thing too! Good Luck & Ride Safe!
__________________
2009 RG w/Wild Ones Chubbys handlebars,Mustang Touring Seat,c/b & intercom, chopped tourpack,hard lowers , 4" RC Components slash cut mufflers & some pinstriping . TNT Motocorp cargo trailer. 97 Road King Classic(hers). Ya don't quit ridin cause ya get old,ya get old cause ya quit ridin

Last edited by Avmech97; 06-12-2010 at 02:01 AM..
Reply With Quote
Old 06-12-2010, 01:58 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signal wont shut off brawner11 Sportster Models 2 03-31-2014 09:37 AM
Bike shuts off when hot Levnim Touring Models 3 10-06-2013 10:40 PM
No spark Johns98roadglide Touring Models 4 06-01-2013 09:00 AM
07 Roadglide Jack Bedard New Members Area 10 11-03-2012 06:18 PM
Road glide seat change chuck2025 Touring Models 2 12-31-2010 03:37 PM


Tags
2001, 2007, classic, codes, davidson, engine, glide, harley, king, motorcycle, reason, riding, road, shut, shuts, ultra


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 06:54 AM.


© Internet Brands, Inc.