Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search


Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 06-26-2011, 06:11 PM
jgann jgann is offline
Hang Around
Join Date: May 2011
Location: Myrtle Beach
Posts: 19
Default cruise control not working

2002 ultra cruise control not working. the light comes on when you flip the switch, but cruise does not engage. What can I check?
Reply With Quote
  #2  
Old 06-26-2011, 06:27 PM
07DDreamHD's Avatar
07DDreamHD 07DDreamHD is offline
Prospect
Join Date: May 2009
Location: Bastrop, LA
Posts: 263
Default

The cruise control is very sensitive. Sometimes it may be the connections and sometimes it may require that you go through the set-up procedures that are listed in your manual. Maybe try to go back through the set-up in the manual. If that does not fix the problem, then check your connections.
Reply With Quote
  #3  
Old 06-26-2011, 06:31 PM
Lito Lito is offline
Hang Around
Join Date: Jun 2011
Location: Gilbert
Posts: 3
Default

I have the same problem. I have checked anything yet let me know what you find out. I have a 2002 rk classic thanks
Reply With Quote
  #4  
Old 06-26-2011, 06:34 PM
Stiggy's Avatar
Stiggy Stiggy is online now
Ultimate HDF Member
Join Date: Nov 2010
Location: Oxford, Nc
Posts: 6,016
Default

Could be as simple as a broken/frayed control cable. I lost one on my 98 Ultra.
__________________

2000 FLTRSEI Stage II 95" Big Bore with Andrews 26 Gear Drives,and a Patriot Defender 2 into 1 Exhaust.
A pick up truck ran the stop sign 2/26/14, and I built a "Screamin' Eagle Road King" out of the salvage.
(And I have a '04 BMW R1200 CL now too.)
Reply With Quote
  #5  
Old 06-26-2011, 06:36 PM
Lito Lito is offline
Hang Around
Join Date: Jun 2011
Location: Gilbert
Posts: 3
Default

I have a 2002 rk classic with 95 big boar kit, 2 into1 thunder header with power commander. Getting ready to install cams and either doing new hydraulic or gear. Any good or bad info to help me make my mind up. 510 cams is what i was thinking
Reply With Quote
  #6  
Old 06-26-2011, 06:37 PM
hd4evr2008's Avatar
hd4evr2008 hd4evr2008 is offline
Road Master
Join Date: Jun 2008
Location: Norwalk, Ohio
Posts: 1,055
Default

http://www.hdforums.com/forum/tourin...sometimes.html
__________________
The older I get, the faster I was!
Reply With Quote
  #7  
Old 06-26-2011, 06:38 PM
Neil's Avatar
Neil Neil is offline
Senior Rider
Join Date: Jun 2006
Location: Cape Cod, Ma.
Posts: 471
Default

I'm having the same problem with my 02. 07DDreamHD, jgann and I have cable operated throtles. I don't think there is any re-set procedure that I have found. If anyone knows of something I would love to hear it. My prblems started after I installed braided brake lines. The switch lights up, the fuse is good but no cruise (no green "C" on the dash). The brake lights work as they are supposed to when the the brakes are applied. Any thoughts?

Neil
RDMC
Reply With Quote
  #8  
Old 06-26-2011, 06:39 PM
vickers1's Avatar
vickers1 vickers1 is offline
Road Warrior
Join Date: Jun 2006
Location: Southeast GA
Posts: 1,740
Default

Follow your throttle cable from the handlebars. You'll find a switch. Unplug one wire from the switch. Ride the bike and check the cruise. If it works, replace the switch.
__________________
"24 hours in a day, 24 beers in a case. Coincidence? I think not."

'08 Street Glide White Gold Pearl [Sold]
'10 Street Glide Merlow & Cherry Red Sunglo [Sold]
'12 Street Glide Ember Red Sunglo, T-Man 555 Torqster Cams, V&H Power Duals, Rineharts, K&N, SEPST
Reply With Quote
  #9  
Old 06-26-2011, 07:12 PM
07custom's Avatar
07custom 07custom is offline
One Of The Regulars
Join Date: Aug 2007
Location: 40 mi South of Pittsburgh
Posts: 116
Default

Is the rear brake light lit all the time? My rear brake switch went, cruise didn't work & the brake light stayed on all the time.
__________________
2007 Ultra Jake & Elwood blue, 103" TW-555, FM 2-1-2, (91 hp, 112 tq)
2007 Custom Jake & Elwood blue, SE 204 cams, V & H big shots staggered

Reply With Quote
  #10  
Old 06-27-2011, 12:37 AM
Potato_Potato's Avatar
Potato_Potato Potato_Potato is offline
Outstanding HDF Member
Join Date: Sep 2005
Location: Minnesota
Posts: 2,577
Default

Check both brake light switches.
__________________


2008 StreetGlide - Stage 1, Bub 7 True Duals, SERT, Corbin Classic Solo, SE Compensator

☮☮☮☮☮☮☮
Reply With Quote
Old 06-27-2011, 12:37 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control not working azzy522 Touring Models 15 08-28-2013 09:42 PM
HARLEY CRUISE CONTROL vs KURYAKYN CRUISE CONTROL ASSIST GRIPS Splais1 Touring Models 9 05-14-2012 09:12 AM
cruise control problem kileygruben Touring Models 9 07-21-2010 09:16 PM
cruise control for super glide meechx Dyna Glide Models 14 01-19-2010 08:11 PM
Cruise control light tatertot Touring Models 8 11-02-2008 07:18 AM


Tags
2002, classic, contro, control, cruise, cruze, davidson, fuse, harley, problem, problems, quit, touring, ultra, work, working


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 03:39 AM.


Internet Brands, Inc.