Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search

Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 10-03-2013, 07:44 PM
ArmyHop's Avatar
ArmyHop ArmyHop is offline
New Member
Join Date: Feb 2012
Location: Arlington,VA
Posts: 44
Default 2013 SG ETIMS and Power Commander V

Hello folks,

So I finally finished all my upgrades and noticed earlier as I was sitting in traffic that my Engine Heat Management doesn't work for some reason. Maybe it's because now the bike shouldn't run as hot as it was stock but I have a feeling that the Power Commander V has something to do with it.

Upgrades I added:

Rinehart Xtreme True Duals w/ 4inch Mufflers
Screamin Eagle Ventilator Air Cleaner
Power Commander V ( with current/newest map for this setup)

I noticed that every time I turn ignition on and roll throttle forward to activate/deactivate the ETIMS it always blinks green as in activated but as soon as I turn the bike completely off and do It again it activates again as it should stay activated and doesn't de activate itself. Weird.

Wonder if anyone else has this problem or maybe it's just me
Reply With Quote
  #2  
Old 10-04-2013, 01:07 PM
ArmyHop's Avatar
ArmyHop ArmyHop is offline
New Member
Join Date: Feb 2012
Location: Arlington,VA
Posts: 44
Default

Looks like I'm the only one who used ETIMS
Reply With Quote
  #3  
Old 10-04-2013, 01:13 PM
Tanker2 Tanker2 is offline
Senior Rider
Join Date: Dec 2007
Location: South West Iowa
Posts: 308
Default

I have a PCV from Fuel Moto. I don't use the Engine Heat Management. I have 4" Rineharts, S&S air cleaner, V&H power duals. Been thinking about trying it. I'll post how it acts when I get around to trying it. But I bet the guys at FuelMoto could answer that question for you.
Reply With Quote
  #4  
Old 10-04-2013, 01:17 PM
fabrik8r fabrik8r is online now
Outstanding HDF Member
Join Date: Jan 2010
Location: earth
Posts: 2,851
Default

I googled "PCV and EITMS" and came up with a bunch of results. If you want a more direct answer, you might try asking DynoJet about this issue?
__________________
Learn from the mistakes of others; less stressful and it'll save you some money.
Reply With Quote
  #5  
Old 10-05-2013, 12:25 AM
ke5rbd ke5rbd is offline
Road Warrior
Join Date: Apr 2010
Location: Monroe, Louisiana
Posts: 1,442
Default

that is pretty normal for it not to activate. I ran a PCV on my 2010 FLHTK for 2 years and the only time it ever activated was in Pigeon Forge and set through 4 red lights trying to turn on 321 at the Harley dealership 2 years ago. Put PV on and still doesn't activate. I monitor with PV and have seen it 280 once while in stop and go construction and 98 ambient. I understand the 2014's have changed the way they activate.
__________________

2014 FLHTK Ultra Classic Limited Mysterious Red Sunglo/Blackened Cayenne Sunglo, Power Vision, 2 in 1 exhaust with ghost pipe.
Reply With Quote
  #6  
Old 10-05-2013, 12:54 AM
ArmyHop's Avatar
ArmyHop ArmyHop is offline
New Member
Join Date: Feb 2012
Location: Arlington,VA
Posts: 44
Default

Thanks for replies. I called the support people and they said that they don't have known issues and that the PCV doesn't change the ECM settings for it and it should work as usual.

I guess that the bike now runs a lot cooler with the new setup and right fuel/air ratio than stock. Just the CAT alone produces a **** ton of heat. We will see what happens. So far the bike runs incredibly smooth.
Reply With Quote
  #7  
Old 10-05-2013, 06:31 AM
jbmss jbmss is offline
New Member
Join Date: Feb 2007
Posts: 64
Default 2013SG ETIMS and Power Commander v

was wondering if your still running your 0-2 sensors with the power commander v?
Reply With Quote
  #8  
Old 10-05-2013, 06:45 AM
WolfDog's Avatar
WolfDog WolfDog is offline
Road Master
Join Date: Aug 2005
Location: North Texas
Posts: 1,078
Default

Mine works just fine.

It gets hot in Texas.
__________________
2010 Ultra Limited, Merlot & Cherry Red Sunglo.
Vance & Hines Power Duals, Monster Rounds.
Fuel Moto High Flow A/C & PCV.
2013 Tuxedo Black Edge Sport.
2012 F-150 Lariat Super Crew Sterling Gray 5.0 Coyote Toy Hauler
2013 F-150 XL Company Ride.
Reply With Quote
  #9  
Old 10-05-2013, 10:02 AM
Reaper22's Avatar
Reaper22 Reaper22 is offline
Road Captain
Join Date: May 2011
Location: Palmyra Missouri
Posts: 565
Default

Quote:
Originally Posted by ArmyHop View Post
Thanks for replies. I called the support people and they said that they don't have known issues and that the PCV doesn't change the ECM settings for it and it should work as usual.

I guess that the bike now runs a lot cooler with the new setup and right fuel/air ratio than stock. Just the CAT alone produces a **** ton of heat. We will see what happens. So far the bike runs incredibly smooth.
I don't believe the tune will stop it from coming on, the 103's get freak'n hot town ride'n, Mine never comes on in town ride'n cuz I have the Ward fans, althou I did hear cams will help cool them down and that makes since :}
__________________


2013 110th Anniversary Edition Ultra Limited (Daughter had pic of bike done in hot metal print for my birthday)
Fuel Moto Jackpot Header, Jackpot 4.5 Pro Touring Mufflers
Power Vision Tuner
Jason Ward's Convection Fans
Reply With Quote
  #10  
Old 10-05-2013, 11:31 AM
ArmyHop's Avatar
ArmyHop ArmyHop is offline
New Member
Join Date: Feb 2012
Location: Arlington,VA
Posts: 44
Default

Quote:
Originally Posted by jbmss View Post
was wondering if your still running your 0-2 sensors with the power commander v?
Nope. Rinehart included bungs I put in instead.
Reply With Quote
Old 10-05-2013, 11:31 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Active Exhaust and Intake Mod 06SGWA General Harley Davidson Chat 2 09-10-2014 04:47 PM
Help needed benjitellez Sportster Models 7 03-21-2013 12:30 PM
ENGINE IDLE TEMPERATURE MANAGEMENT SYSTEM FOR 08 BAGGER DRAGO1 Exhaust System Topics 3 03-11-2013 08:18 AM
Installed new siren II but it doesn't come on Phochief Softail Models 22 01-25-2013 01:54 PM
Cruise Control Activation les63 Touring Models 7 10-07-2010 03:39 PM



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 09:46 PM.


Internet Brands, Inc.