2008 Road King Cleaned Throttle body electrical connector, now it wont crank? - Harley Davidson Forums



Electrical/Lighting/Alarm Having electrical problems? Discussion on everything electrical and lighting systems.

2008 Road King Cleaned Throttle body electrical connector, now it wont crank?

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 07-16-2017, 09:33 AM
trigger1911 trigger1911 is offline
One Of The Regulars
Thread Starter
Join Date: Jan 2007
Posts: 188
Thanked 1 Time in 1 Post
Default 2008 Road King Cleaned Throttle body electrical connector, now it wont crank?

So my 2008 FLHR Road King went into safe mode yesterday. Rode home in first gear and parked it in the garage. Read the forums on cleaning the connector behind the air cleaner and applying dielectric grease and reassembled. Now it wont crank but the starter relay in the fuse box clicks. I also have no turn signals or 4-ways but they flash for the security system. I also have no horn and brake lights, but the headlights, taillights and the battery are all good. The most confusing thing is that I have a Hoppe Quadzilla fairing with a radio and that also wont come on and it is not even connected to any of the electrical system, just wired straight to the battery. I double checked each fuse and relay and they are all good. The only thing I can figure out is that I had to lift up the gas tank to get the connector apart. If I have the ignition on and I lift up the tank everything goes blank until I lower it to a certain point. I also think I put too much grease on the terminal on the throttle body side of the connector so I used a metal screwdriver to scrape some out without unplugging the negative battery lead. So much for riding on the one day I had off in 2 weeks!
Reply With Quote
  #2  
Old 07-16-2017, 10:30 AM
trigger1911 trigger1911 is offline
One Of The Regulars
Thread Starter
Join Date: Jan 2007
Posts: 188
Thanked 1 Time in 1 Post
Default

I found the problem!!!! The wiring harness under the dash started to come off because the retaining clips were worn. It was just loose enough to come off one side. I put a zip tie around it and everything works fine.
Attached Thumbnails
2008 Road King Cleaned Throttle body electrical connector, now it wont crank?-20170716_105315-1-.jpg   2008 Road King Cleaned Throttle body electrical connector, now it wont crank?-20170716_105323-1-.jpg   2008 Road King Cleaned Throttle body electrical connector, now it wont crank?-20170716_105335-1-.jpg  
Reply With Quote
The Following User Says Thank You to trigger1911 For This Useful Post:
Dan89FLSTC (07-17-2017)
  #3  
Old 07-17-2017, 10:55 AM
larsfum larsfum is offline
Road Warrior
Join Date: Jan 2009
Location: St. Pete
Posts: 1,535
Thanked 91 Times in 80 Posts
Default

Thanks for reporting the answer. You may help someone else down the road.
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Hey Y'all! Electrical Problems Johnny Lignite Touring Models 8 07-14-2017 02:31 PM
Clean your Ignition Switch - Prevent Stalling While Riding Joe_G Softail Models 66 06-13-2017 10:24 AM
1998 Road King FLHRCI - Intermittant Misfire Problem bmur66 Evo Classic Models 29 06-03-2017 09:29 AM
Electrical Help... WTF??? Pothole914 General Harley Davidson Chat 31 05-21-2017 08:14 PM
2002 Road King Not Getting Fuel RD WOYER Touring Models 4 05-21-2011 01:53 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:58 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: