Negative Terminal Sparking with new Battery - Harley Davidson Forums

Electrical/Lighting/Alarm Having electrical problems? Discussion on everything electrical and lighting systems.

Negative Terminal Sparking with new Battery

  #1  
Old 07-14-2018, 01:31 AM
Ger12
Ger12 is offline
New Member
Thread Starter
Join Date: Jul 2018
Location: California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Negative Terminal Sparking with new Battery

I recently bought a 2003 Super Glide Anniversary Edition. The previous owner has been it for a couple of years now without a battery, I recently bought a new battery for it, and when ever I try to connect the negative lead it sparks consistently melting away the negative terminal. I am wondering if it is caused by shortage or could this be due to a bad fuse?
 
  #2  
Old 07-14-2018, 03:51 AM
OzHD's Avatar
OzHD
OzHD is offline
Road Warrior
Join Date: Jul 2018
Location: Mandurah, West Oz
Posts: 1,378
Thanked 373 Times in 254 Posts
Default

If it sparks enough to melt the terminal it's a short somewhere - a huge current draw. A fuse should blow to open circuit.
 
  #3  
Old 07-14-2018, 03:58 AM
Kingglide549's Avatar
Kingglide549
Kingglide549 is offline
Outstanding HDF Member
Join Date: May 2018
Location: Viet Vet, crossroads
Posts: 2,884
Thanked 591 Times in 420 Posts
Default

Pull all your fuses and solenoids try it.
If that works- install one fuse/ solenoid circuit at a time till you find the guilty circuit.
 
  #4  
Old 07-14-2018, 05:09 AM
nzhd
nzhd is offline
One Of The Regulars
Join Date: Jul 2017
Location: :
Posts: 165
Thanked 24 Times in 17 Posts
Default

My Softail Sparks a bit when connecting negative, postitive already connected. Something on the bike is powering up. (Key off)
but as far as I can tell it's normal, I have no issues. But mine is not melting the terminal.
 
  #5  
Old 07-14-2018, 08:16 PM
Ger12
Ger12 is offline
New Member
Thread Starter
Join Date: Jul 2018
Location: California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

so i disconnected the ignition switch and plug the battery back and it still sparked consistently, so then i disconnected all the fuses and it still sparked.



The negative terminal


fuse box

 
  #6  
Old 07-16-2018, 02:19 PM
Vernal's Avatar
Vernal
Vernal is offline
Club Member
Join Date: Apr 2013
Location: Utah
Posts: 3,600
Thanked 386 Times in 311 Posts
Default

I suspect a short to ground on the positive cable between the battery and the circuit breaker. Pull the Black wire from the Circuit Breaker and check resistance between that wire and ground.
Go to sheet one of 11 for Dyna
https://serviceinfo.harley-davidson....68bed396!!4!22
 

Last edited by Vernal; 07-16-2018 at 02:22 PM.
  #7  
Old 07-18-2018, 11:14 PM
cficole's Avatar
cficole
cficole is offline
Outstanding HDF Member
Join Date: Jul 2014
Location: Lake County, IL
Posts: 2,031
Thanked 160 Times in 136 Posts
Default

What Vernal said, and don't forget to report back.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
USAFANGWINGNUT67
Electrical/Lighting/Alarm
4
12-07-2015 08:03 PM
junglebill
Touring Models
2
06-07-2015 10:17 AM
f3fidy
Dyna Glide Models
5
04-08-2014 08:31 PM
hdpig
Ignition/Tuner/ECM/Fuel Injection
2
12-27-2006 12:21 AM
hdpig
Ignition/Tuner/ECM/Fuel Injection
12
04-30-2006 01:30 AM


Thread Tools
Search this Thread
Quick Reply: Negative Terminal Sparking with new Battery


Featured Sponsors
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: