2003 883 not starting solenoid/relay ? - Harley Davidson Forums



Electrical/Lighting/Alarm Having electrical problems? Discussion on everything electrical and lighting systems.

2003 883 not starting solenoid/relay ?

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 03-18-2013, 11:47 AM
naturalhighvpc naturalhighvpc is offline
New Member
Thread Starter
Join Date: Mar 2013
Location: vermont
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2003 883 not starting solenoid/relay ?

I have a 2003 sportster 883 over the winter I did some work, side mount plate and tail light,coil & ignition relocation, new builtwell bars new paint. When I got it all back together all seemed good all the lights worked and systems came to life but when I hit the start button I got NOTHING. I checked the (4) 15amp fuses in the fuse box, all are good. although when I was hooking up the tail light on the side mount bracket I did blow some of those 15amp fuses I replaced them right away and moved on.
? could I have blown the starter relay located by those fuses at the same time I blew the 15 amp fuse?
? how do I know if the starter relay is blown ?
? could one of my problems be the starter solenoid?
any help in diagnosing this would help greatly Thanks VC
Reply With Quote
  #2  
Old 03-18-2013, 08:15 PM
UltraNutZ's Avatar
UltraNutZ UltraNutZ is offline
Audio Forum Moderator
Join Date: Nov 2007
Location: East of the Sun, West of the Moon
Posts: 14,669
Thanked 93 Times in 80 Posts
Default

ignition switch relocation? are you sure you go the wires back on correctly?

easy way to tell about the relay is listen for it to click when you hit the start button. if it's not clicking, then you're either not getting power to it or you're not getting the start button feed to it.
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Unedited: Adding a second relay to fix the dreaded click D1gger Evo Classic Models 211 08-24-2017 07:28 AM
It's a non starter.... deluxe Softail Models 13 05-17-2017 06:22 PM
1999 Sportster 1200 Starting problems aperry199523 Sportster Models 4 03-26-2017 12:27 PM
Brake light relay on an 06 Ultra Classic Armed_Infidel_77 Electrical/Lighting/Alarm 1 04-21-2016 09:10 PM
Bike Died and Won't Start toddincharlotte Touring Models 24 07-30-2015 05:07 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 08:56 AM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: