2009 883 Not Starting - Harley Davidson Forums



Ignition/Tuner/ECM/Fuel Injection Need advice on ignition issues? Questions about a tuner? Have questions about a EFI calibration or Fuel Injection? Tips on Engine Diagnostics, how to get codes, and what they mean. Find your answers here.

2009 883 Not Starting

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 05-17-2017, 06:36 PM
Drew Andrioff Drew Andrioff is offline
New Member
Thread Starter
Join Date: May 2017
Location: San Diego
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 2009 883 Not Starting

Bike was running fine on Monday. Went to start it on Tuesday - turned the key acc power came on - fuel pump came on - went to click run button and nothing. No click no sounds nothing. Turned it off and tried again - same. Checked fuses / relays / terminal connections or any loose connections. Pulled the battery and put it on a tender over night to ensure no power issues. Still nothing. Took housing apart looks fine. Any advice or suggestions?
Reply With Quote
  #2  
Old 05-17-2017, 06:42 PM
saltlick's Avatar
saltlick saltlick is offline
Road Master
Join Date: Sep 2006
Location:
Posts: 866
Thanked 32 Times in 27 Posts
Default

Check to make sure the kill switch isnt on.

Replace the battery (even if you think its good, could have a dead cell)

Put it in neutral and try it again.

Does it have an alarm on it? Maybe it needs the code put in so it can start. Maybe the FOB is dead.
Reply With Quote
  #3  
Old 05-17-2017, 07:08 PM
Drew Andrioff Drew Andrioff is offline
New Member
Thread Starter
Join Date: May 2017
Location: San Diego
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Kill switch on bars is not on. No idea if it has an alarm. Bought the bike used couple years back. No FOB. Never had any issues like this. Bike has always cranked first try. This is first issue I've ever had. Literally took it out to put gas in it - put in garage - went to fire it up for work and nothing.
Reply With Quote
  #4  
Old 05-18-2017, 12:13 PM
nevil's Avatar
nevil nevil is online now
Ultimate HDF Member
Join Date: Jul 2008
Location: southeast PA
Posts: 6,101
Thanked 123 Times in 112 Posts
Default

Did you check the battery ground cable connection?
Reply With Quote
  #5  
Old 05-18-2017, 03:33 PM
baloot-boy's Avatar
baloot-boy baloot-boy is online now
Road Captain
Join Date: May 2014
Location: San Diego
Posts: 592
Thanked 22 Times in 21 Posts
Default

Could be the starter relay. Find it on your bike and clean the connections. Or get one from Harley...its only $7. If thats not the fix, at least you have a spare.
Reply With Quote
  #6  
Old 05-19-2017, 08:02 PM
Drew Andrioff Drew Andrioff is offline
New Member
Thread Starter
Join Date: May 2017
Location: San Diego
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Already tried swapping relays. No luck.
Reply With Quote
  #7  
Old 05-20-2017, 09:20 AM
baloot-boy's Avatar
baloot-boy baloot-boy is online now
Road Captain
Join Date: May 2014
Location: San Diego
Posts: 592
Thanked 22 Times in 21 Posts
Default

Quote:
Originally Posted by Drew Andrioff View Post
Already tried swapping relays. No luck.
Also saw that you put a tender on the battery overnight to ensure it was charged. A tender or a regular charger won't charge a battery if its completely dead.

Also to narrow down your issue, pull the solenoid cover (3 screws) and press the rubber boot cover with a screw driver to try to start. If it starts, it will tell you there's an electrical issue between your start button and your starter relay.
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help with my 07 RK Classic ABN_Daddy Touring Models 7 07-27-2017 12:59 PM
My 2014 Sportster did just one click and won't start. iron883dreamer Sportster Models 2 07-03-2017 08:06 PM
red key light no turn signals 78camarob Sportster Models 14 05-28-2016 09:21 AM
03 road king starter clicks cajun1957a Touring Models 25 11-21-2015 06:34 AM
2001 Heritage security system issue gwharley Electrical/Lighting/Alarm 2 10-26-2015 09:08 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 12:00 PM.


 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: