Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Evo Classic Models
Sign in using an external account
Register Forgot Password?
Search


Evo Classic Models All Evo Models
Sponsored by: J&M Motorcycle Audio

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 04-23-2012, 04:10 AM
tc's Avatar
tc tc is offline
One Of The Regulars
Join Date: Feb 2007
Location: Dublin, Ireland.
Posts: 135
Default backfiring......

Went for a spin yesterday, about 120miles or so. After maybe 80 started to rain heavy so stopped for coffee for a half hour or so. Very heavy rain during that time and bike was not covered at all.
Came out and headed off. It started loud backfiring and missing very badly for about 15 mins. If I kept speed around 45/50ish, not too bad, but try to accelerate and put load on engine, no hope. Would start and idle no problem.
Obviously, after that time it dried out and ran like its brilliant self.
Just wondering if anyone could point me in right direction of where water got in?
I feel it may have been ignition switch which is the old mechanical type,but any other suggestions or experiences welcome.

As usual, thanks to all who may reply.

TC
__________________
I Like Simple, Simple is Good.

1986 FLSTC. 1340, S&S carb, Scremin Eagle Ignition Module, EV27, 2 1/4" Straight Thru pipes with Khrome Werks Baffles.
Reply With Quote
  #2  
Old 04-23-2012, 04:20 AM
FXD_One's Avatar
FXD_One FXD_One is offline
Prospect
Join Date: Sep 2011
Location: Ontario, Canada
Posts: 236
Default

Check the coil for cracks in the housing and the wires for splits or wear. Problems like this can be difficult, persist and you'll find it.

If I can add one other thing...once you've found the problem. Protect all your electrical connections with a dab of dielectric grease. It's silicon based, will not become alkaline or acidic over time and will keep connectors waterproof and free of corosion.

All the best
__________________
Molly - 1998 Dyna Super Glide.
Andrews EV-27 cam, Killer MC Carb, Supertrapp 2:1, Crane HI-4 ignition, Big sucker air intake, SE Adjustable push rods, Metal breather gear.
Reply With Quote
  #3  
Old 04-23-2012, 04:28 AM
tc's Avatar
tc tc is offline
One Of The Regulars
Join Date: Feb 2007
Location: Dublin, Ireland.
Posts: 135
Default

thanks for quick reply, fxd_1.

One other bit of info. I did ride for about 15 minutes in torrential rain, so water could have been "forced" in somewhere!!!!!!!
__________________
I Like Simple, Simple is Good.

1986 FLSTC. 1340, S&S carb, Scremin Eagle Ignition Module, EV27, 2 1/4" Straight Thru pipes with Khrome Werks Baffles.
Reply With Quote
Old 04-23-2012, 04:28 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
1988 Sportster intermittent to no spark vasol Sportster Models 6 08-29-2014 06:53 PM
Bad misfire/backfire wiski11 Ignition/Tuner/ECM/Fuel Injection 0 07-26-2014 05:17 PM
Help! Intermittent running bad issue blueglide88 Touring Models 9 08-27-2013 10:18 AM
1200 custom carb problem HELP Dzlsnowman Sportster Models 5 06-23-2013 02:29 PM
My octane test strtarrow Touring Models 20 05-30-2011 12:16 PM


Tags
harley, heavy, missing, rain


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 03:41 AM.


Internet Brands, Inc.