Idles great but dies when you go to take off - Harley Davidson Forums



Evo Classic Models All Evo Models

Idles great but dies when you go to take off

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 12-14-2012, 10:44 AM
lawdog150 lawdog150 is offline
New Member
Thread Starter
Join Date: Aug 2011
Location: Leitchfield, Ky
Posts: 12
Thanked 1 Time in 1 Post
Default Idles great but dies when you go to take off

I just got a 91 Electra Glide that had set for 2 years. Cleaned carb and started right up. Idles great and it will take gas but when you put it in gear and go to take off it dies. Have took carb apart several times can't find anything wrong and it does the same thing. This is above my pay grade I am lost need held.
Reply With Quote
  #2  
Old 12-14-2012, 10:51 AM
jimsflh's Avatar
jimsflh jimsflh is offline
Outstanding HDF Member
Join Date: Aug 2008
Location: Michigan
Posts: 3,078
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Petcock screen clogged? Fuel line clogged?
When you say it will take gas, do you mean you can rev the **** out of it and it runs fine?
Reply With Quote
  #3  
Old 12-14-2012, 11:26 AM
Dr.Hess Dr.Hess is online now
Elite HDF Member
Join Date: Aug 2007
Location: NW AR
Posts: 4,699
Thanked 29 Times in 29 Posts
Default

What carb does this have? If the fuel line/filter is OK, then I'd say your intermediate and/or main jet is clogged.
Reply With Quote
  #4  
Old 12-14-2012, 12:02 PM
lawdog150 lawdog150 is offline
New Member
Thread Starter
Join Date: Aug 2011
Location: Leitchfield, Ky
Posts: 12
Thanked 1 Time in 1 Post
Default

It has cv-40 carb. It will rev up and run fine but when you start to take off it dies. Took inline filter off still the same.
Reply With Quote
  #5  
Old 12-14-2012, 12:16 PM
miacycles's Avatar
miacycles miacycles is offline
Elite HDF Member
Join Date: Sep 2007
Location: Bluffton, South Carolina
Posts: 4,470
Thanks: 0
Thanked 1 Time in 1 Post
Default

Two things to check right off, if you have no vacuum leaks. First check the accelerator pump. When you twist the throttle there should be some fuel squirting into the carbs venturi. Secondly there is a little silver needle jet that sticks up into the venturi and the needle sticks into it. This piece has to be put in right or you can have the troubles you describe. One end has a radius on the inside and the other is square. The radiused end needs to be up so that the needle goes into that.
A few other possibilities: low float level, torn diaphragm on the slide, sticky slide, or carb still dirty or improperly assembled. Hope this helps.
John
Reply With Quote
  #6  
Old 12-14-2012, 04:30 PM
j1mmy's Avatar
j1mmy j1mmy is offline
Elite HDF Member
Join Date: Dec 2009
Location: navarre ohio
Posts: 4,595
Thanks: 0
Thanked 0 Times in 0 Posts
Default

when i was cleaning carbs almost daily at a shop, i still had to go back and reclean one 2-3 times sometimes. there are ports and passages built in to the carb body. some are only big enough to stick a single strand from a wire in to get clean.. the jets are only a small part of cleaning the carb.. plus everything mentioned above could be the problem.. a lot of people will clean the carb, but leave the metering needle dirty.. just some suggestions.
Reply With Quote
  #7  
Old 12-14-2012, 08:16 PM
machinehed machinehed is offline
Road Master
Join Date: Oct 2011
Location: Carlsbad Springs Ontario
Posts: 957
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Its probably carb. related but as dumb as this sounds ... have you rolled the bike in neutral to see if the brakes are stuck or something that is preventing the bike from moving .?
If all is well , try reving the motor past idle rpm and hold the brakes on to see if it dies under load as you describe.
Be carefull and let us know what you find.
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
really confusing START, but wont stay running.... HDsportster99 Engine Mechanical Topics 3 11-02-2016 12:03 AM
'94 road king idle drops BT80 Evo Classic Models 26 09-29-2016 03:14 PM
81 carb help buellxb422 Ironhead 3 04-25-2016 09:13 AM
2005 883 carb slide issue rodgini Exhaust System Topics 6 10-04-2013 07:29 AM
Carb adjustment/blue flame out of exhaust cadillac6661 Shovelhead 2 11-05-2011 11:27 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT -5. The time now is 01:35 PM.