Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Softail Models
Sign in using an external account
Register Forgot Password?
Search

Softail Models Standard, Custom, Night Train, Deuce, Springer, Heritage, Fatboy, Deluxe, Rocker and Cross Bones.

Welcome to HDForums.com!

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 05-25-2009, 10:47 AM
harleylay's Avatar
harleylay harleylay is offline
One Of The Regulars
Join Date: Feb 2009
Posts: 107
Default Transmission fluid

Is the tranny fluid the same as the motor oil I know primary fluid is different but cant remember about tranny.
Reply With Quote
  #2  
Old 05-25-2009, 11:03 AM
Xuallus's Avatar
Xuallus Xuallus is offline
Road Master
Join Date: Nov 2008
Location: Alberta, Canada
Posts: 851
Default

I run Amsoil in all 3 holes, there are some HUGE threads about it...

http://hdforums.com/forum/oil-and-oi...ted-topics-30/
__________________


Reply With Quote
  #3  
Old 05-25-2009, 06:22 PM
Heath Heath is offline
Former Sponsor
Join Date: May 2008
Location: Mason City, Iowa
Posts: 303
Default

From the factory it's usually HD 360 in the engine and Formula+ in the primary and tranny. This is also a 50 weight oil, so you can use amsoil, syn3, etc. in all 3 holes.
The primary needs an oil that is we clutch compatible. The tranny can use an oil or a gear lube, whatever your preference.
Reply With Quote
  #4  
Old 05-26-2009, 07:01 AM
tk353's Avatar
tk353 tk353 is offline
Ultimate HDF Member
Join Date: Oct 2007
Location: Leander Texas
Posts: 5,258
Send a message via Yahoo to tk353
Default

I run the oil in the engine but use Bel ray for the trans and no wine or clank and I can find neutral. I use Motor Factory® Primary Case Lube in the primary. because Amsoil has gone up so much I just switched to Mobil 1 for vtwin and it works as good. I have 30,000 miles in about 1.5 years and it runs great and no debris in the oil changes.
http://www.belray.com/consumer/product.fsp?pid=13637
http://www.customchrome.com/dcm/cc/view.asp?mfoil.html
__________________

2007 Fatboy
Hooker Rebel Exhaust, Arlen Ness Big Sucker, Mustang seat, RearAlert
Thundermax, 60,000 miles, Cross Bones D401 200/55r-17 rear
http://gallery.me.com/tk353
Reply With Quote
  #5  
Old 05-26-2009, 07:12 AM
oct1949's Avatar
oct1949 oct1949 is online now
Club Member
Join Date: May 2007
Location: Ind, N of Purgatory
Posts: 46,465
Default

syn3 in motor, formula+ in primary, just started using Belray hypiod 80-140 in tranny, like it better than formula+.
__________________
07Heritage -47K
26 cams,
Bunch of bling and leather.
Reply With Quote
  #6  
Old 06-22-2009, 10:06 AM
johneb09 johneb09 is offline
Hang Around
Join Date: Jun 2009
Posts: 8
Default tranny fluid

I have an 09 HD Elec.Glide that I purchased new a couple weeks ago. I'm taking it in for the 1,000 mile service this week. I requested to have them put Bel Ray tranny fluid back in, but they said that the thicker fluid has caused the neutral and 6 speed indicator lights to not function properly. Anyone have any suggestions ? 5th gear is a little noisy, and I was hoping to quiet it down some.
Reply With Quote
  #7  
Old 06-22-2009, 10:17 AM
aviscomi's Avatar
aviscomi aviscomi is offline
Outstanding HDF Member
Join Date: Jul 2007
Location: Philadelphia
Posts: 2,017
tviscomi
Default

Quote:
Originally Posted by johneb09 View Post
I have an 09 HD Elec.Glide that I purchased new a couple weeks ago. I'm taking it in for the 1,000 mile service this week. I requested to have them put Bel Ray tranny fluid back in, but they said that the thicker fluid has caused the neutral and 6 speed indicator lights to not function properly. Anyone have any suggestions ? 5th gear is a little noisy, and I was hoping to quiet it down some.
Hmm...that sounds like BS.
__________________
2013 StreetGlide Denim Black-V&H Hi Output Stainless Steel Duals, Roland Sands Black Ops A/C, PCV, Progressive Monotubes -1
Reply With Quote
  #8  
Old 06-22-2009, 12:55 PM
mke125125 mke125125 is offline
Road Captain
Join Date: Jan 2008
Posts: 676
Default

I use mobile1 75/90 gear oil in the tranny and my indicator lights work just fine.
__________________
mke125125
Reply With Quote
  #9  
Old 06-22-2009, 01:01 PM
DECON BLUE's Avatar
DECON BLUE DECON BLUE is offline
Road Captain
Join Date: Nov 2007
Location: Port Richey, Florida
Posts: 521
Question

Sounds like more Stealership BS to me, I been running it in my 08 6 speed for 29000 miles with no problem.
Reply With Quote
  #10  
Old 06-22-2009, 04:45 PM
pearlandhd's Avatar
pearlandhd pearlandhd is offline
Prospect
Join Date: Jul 2008
Location: Pearland, Texas
Posts: 181
Default

I run Belray in the trans and haven't had a light misfunction. That's not to say the stealership hasn't seen the problem before, however, if that were a real problem I'd expect someone would have posted it on this board before.
__________________
09 Fatboy Vivid Black, 16" Carlini Apes, V&H BSS, PCV, Zippers Hi-Flow, Chrome crap
07 Street Bob Vivid Black, V&H Big Radius, PCIII, Ness Big Sucker, Flames
Reply With Quote
Old 06-22-2009, 04:45 PM
 
 
 
P
Reply

Tags
davidson, fluid, formula, glide, harley, hd, oil, primary, rsd, street, streetglide, substitute, tranny, trans, transmission


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off
Forum Jump

Advertising
Featured Sponsors
Vendor Directory
Sponsors
All times are GMT -5. The time now is 12:04 PM.

© Internet Brands, Inc.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.5.2

Admin, Emails & Contact Details