Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search


Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 04-24-2011, 09:23 PM
TickTock's Avatar
TickTock TickTock is offline
Club Member
Join Date: Feb 2007
Posts: 1,662
Default P1511 p2101

Well I knew it was too good to be true when my main wiring harness was replaced a few months ago to fix this issue. My 2011 EGC threw these AGAIN twice after refueling. Only problem is that I am 750 miles from home actually using my touring bike for touring...

Anyway when this happens bike goes into limp home mode. I ended up pulling the master fuse both times to clear it. Bike runs fine after that and does not repeat episode right away.

Want to note that every single incident has been after refueling - even before new harness. The moco response has typically been cleaning/replacing pins into the ECM but I think it is something else, especially since I received a new wiring harness.

Anyone else experiencing this after refueling?
Reply With Quote
  #2  
Old 04-24-2011, 09:32 PM
SpiderPig's Avatar
SpiderPig SpiderPig is offline
Outstanding HDF Member
Join Date: Jan 2008
Location: Illinois
Posts: 2,245
Default

I have read on here that others have greased up the pins on the ECM connectors with dielectric grease that helped the issue. Not sure why this is happening after you refuel, sorry no help there. Hope you get it figured out. Many smarter folks on here than me. I am sure someone will chime in.
__________________
http://i720.photobucket.com/albums/ww207/Col_Steege/CameraPictures144.jpg
2010 Limited Catless Headpipe, V&H M.O's, K&N HiFlow A/C Kit,Vied's and SE Compensator
2006 Ultra 103" Kit/PC III, SE HTCC Heads, Flat Top pistons, Andrews 54g, Rinehart True Duals
93 Softail Custom, V&H BigShots
Illinois Patriot Guard Rider
Reply With Quote
  #3  
Old 04-24-2011, 09:32 PM
1931jamesw's Avatar
1931jamesw 1931jamesw is offline
Ultimate HDF Member
Join Date: Nov 2008
Posts: 6,683
Default

Those kind of problems are the worst. Sorry you're having to deal with them. What are those codes indicative of and what year bike are we talking?
__________________

Hawg Wired, Gauges by Marty, Big Sucker AC, Big Boyz Heads, Throttle Body Ported In House, TMan Cams, Drago's Bike Works Dragula, TTS MasterTune
Reply With Quote
  #4  
Old 04-24-2011, 09:37 PM
SpiderPig's Avatar
SpiderPig SpiderPig is offline
Outstanding HDF Member
Join Date: Jan 2008
Location: Illinois
Posts: 2,245
Default

Here is a link to the codes if it helps you;
http://www.hdforums.com/forum/electr...tic-codes.html
__________________
http://i720.photobucket.com/albums/ww207/Col_Steege/CameraPictures144.jpg
2010 Limited Catless Headpipe, V&H M.O's, K&N HiFlow A/C Kit,Vied's and SE Compensator
2006 Ultra 103" Kit/PC III, SE HTCC Heads, Flat Top pistons, Andrews 54g, Rinehart True Duals
93 Softail Custom, V&H BigShots
Illinois Patriot Guard Rider
Reply With Quote
  #5  
Old 04-24-2011, 09:43 PM
SpiderPig's Avatar
SpiderPig SpiderPig is offline
Outstanding HDF Member
Join Date: Jan 2008
Location: Illinois
Posts: 2,245
Default

TickTockYou have a PM
__________________
http://i720.photobucket.com/albums/ww207/Col_Steege/CameraPictures144.jpg
2010 Limited Catless Headpipe, V&H M.O's, K&N HiFlow A/C Kit,Vied's and SE Compensator
2006 Ultra 103" Kit/PC III, SE HTCC Heads, Flat Top pistons, Andrews 54g, Rinehart True Duals
93 Softail Custom, V&H BigShots
Illinois Patriot Guard Rider

Last edited by SpiderPig; 04-24-2011 at 09:46 PM..
Reply With Quote
  #6  
Old 04-24-2011, 09:59 PM
TickTock's Avatar
TickTock TickTock is offline
Club Member
Join Date: Feb 2007
Posts: 1,662
Default

Like mentioned earlier pins were replaced when the main harness was replaced. This was on consult from my dealer from moco. Not sure what the problem really is but bike is hot and it is after a refuel. Very first time bike had 300 miles on it.

This trip it happened on separate days but both in the afternoon. I had fueled earlier in the day with no issues.
Reply With Quote
  #7  
Old 05-07-2011, 08:26 AM
TickTock's Avatar
TickTock TickTock is offline
Club Member
Join Date: Feb 2007
Posts: 1,662
Default

Just to update a resolution - the dealer is working with motor company to get a new ecm download that is not quite released yet. I don't quite understand it (so my explanation might not be quite right), but there is some diagnostic check the occurs when shutting down the engine that determines where the throttle position is and the position of the throttle plate. Apparently the current stock calibration doesn't have enough latency built in and the check occurs too fast - thereby throwing the code. There is supposedly not a physical problem with the bike and so their fix is to update the ECM table that controls the amount of time it waits before performing the check.

So for the record this is what has been done so far:
1.) Clean ECM Pins
2.) Replace ECM Pins
3.) Replace main wiring harness
4.) Receive new stock download

The table being updated in the ECM is also in an area that the current tuners such as TTS and PowerVision do not flash. This is more of a firmware flash.

Keywords for search 1511 - 2101 - p1511 - p2101
Reply With Quote
  #8  
Old 05-07-2011, 10:14 AM
hrchdog's Avatar
hrchdog hrchdog is offline
Senior Rider
Join Date: Mar 2007
Location: Southern Illinois
Posts: 301
Default

Quote:
Originally Posted by TickTock View Post
Just to update a resolution - the dealer is working with motor company to get a new ecm download that is not quite released yet. I don't quite understand it (so my explanation might not be quite right), but there is some diagnostic check the occurs when shutting down the engine that determines where the throttle position is and the position of the throttle plate. Apparently the current stock calibration doesn't have enough latency built in and the check occurs too fast - thereby throwing the code. There is supposedly not a physical problem with the bike and so their fix is to update the ECM table that controls the amount of time it waits before performing the check.

So for the record this is what has been done so far:
1.) Clean ECM Pins
2.) Replace ECM Pins
3.) Replace main wiring harness
4.) Receive new stock download

The table being updated in the ECM is also in an area that the current tuners such as TTS and PowerVision do not flash. This is more of a firmware flash.

Keywords for search 1511 - 2101 - p1511 - p2101
Subscribing, my new 2011 limited did the same thing last night after refueling and had the same codes.
Reply With Quote
  #9  
Old 05-07-2011, 10:19 AM
1flhtk4me 1flhtk4me is offline
Ultimate HDF Member
Join Date: Apr 2006
Location: Hollister,California.
Posts: 9,872
Default

Just a stupid thought,could it have something to with re-setting the trip gauge?
__________________
2011 Electra Glide Limited,Fuel Moto stainless headpipe,Jackpots,PCV,SE/K&N.
Reply With Quote
  #10  
Old 05-07-2011, 10:46 AM
TickTock's Avatar
TickTock TickTock is offline
Club Member
Join Date: Feb 2007
Posts: 1,662
Default

Quote:
Originally Posted by 1flhtk4me View Post
Just a stupid thought,could it have something to with re-setting the trip gauge?
No, IMHO I think it is the diagnostic test failure like I described earlier. To me that makes more sense than a corroded pin. I had this happen the very first time in the first month I had the bike with 300 miles on it.

Often I reset the trip gauge after I have started the bike. What occurs is that when you turn the ignition switch on, the check engine light comes on and stays on.
Reply With Quote
Old 05-07-2011, 10:46 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas fumes when garaged fmgsr Tri Glide & Freewheeler Models 6 10-29-2014 07:11 PM
Gas Station / Refuel Pics 1HDRIO Sportster Models 36 06-20-2014 11:35 AM
Where do you put your gas cap when fueling up? Boxer 6 General Harley Davidson Chat 718 04-07-2014 06:31 AM
Splash Back When Refuelling 6 Gallon Tank tmoreau Touring Models 68 10-26-2010 06:16 PM
Sportster sputters after fuel light goes on. bertmccarrthy Sportster Models 4 11-06-2007 02:38 AM


Tags
1511, 2011, 2101, 585g, cams, code, codes, davidson, ecm, harley, heads, htcc, p1511, p2101, reset, ss, touring, trouble


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 02:25 AM.


Internet Brands, Inc.