Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search


Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Welcome to HDForums.com!

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 07-08-2008, 06:02 PM
buckmc's Avatar
buckmc buckmc is offline
Prospect
Join Date: Jan 2008
Location: Glenmora,La
Posts: 243
Default 2001 Electra glide speedo problems

My 2001 glide,has a speedo problem,that it has had sense it was new in 2001. when your bike is cold,the speedo won't register. I get going about 40mph,and kill my motor,put it in 5th come out on the clutch slow,when it fire's the speedo works,9 times out of 10. I've had it at Harley shop at least 7 time's about this.they gave me a new speedo gauge when it was new and under warrenty.One time they changed the speed senser,on the transmission.Called me said come,and get it,I did it stopped working before I could get home. I put a 6 speed gear set in it in 2003,and I got a recalibration unit to put inline,to adjust for the new gear.It worked fine for about 3 month's then started again. Well I have it down to check it out.I've got 12 volt's to the recail unit,all connection's seem to be good. It'll stop working,and you can unplug one side of the recail unit and plug it up again.it'll work for a few time's then the same thing happen's.does anyone have any suggestion's to this problem,could it be inside mt faring?How do you remove it?&nbsp\\;
__________________
MG McDonald
Reply With Quote
  #2  
Old 07-08-2008, 06:37 PM
spam62638789 spam62638789 is offline
Hang Around
Join Date: Jun 2008
Location:
Posts: 63
Default RE: 2001 Electra glide speedo problems

I had one with faulty needle that would fall below the 0 MPH post and get stuck when it was sitting in the sun.&nbsp\\;
&nbsp\\;
Is it the mechanical part of the speedo or electrics?&nbsp\\; I'd suspect the wiring harness/connectors if its electrics.&nbsp\\; Loose connection in the connector itself or could be in the wire.&nbsp\\; Intermittent problems are hardest to diagnose.&nbsp\\;&nbsp\\;&nbsp\\;Some&nbsp\\;of the quick disconnect plugs can have poor contact or corrosion.&nbsp\\; Wouldn't expect it on a new bike but you never know.&nbsp\\; Good luck.
__________________
Scott
www.ride2ns.com

2000 EG STD 96in
6 Speed
Sampson true duals
XR650 for mountains and desert
Reply With Quote
  #3  
Old 07-09-2008, 07:09 AM
buckmc's Avatar
buckmc buckmc is offline
Prospect
Join Date: Jan 2008
Location: Glenmora,La
Posts: 243
Default RE: 2001 Electra glide speedo problems

My bike is a 2001,just trying to find a course of action,It's looking more,and more like a tank pull,and faring disassemble,to trace wiring. Man what a bummer,but could be worse
__________________
MG McDonald
Reply With Quote
  #4  
Old 07-09-2008, 07:47 AM
huffhuff huffhuff is offline
Road Warrior
Join Date: Sep 2005
Location: guntersville, al
Posts: 1,942
Default RE: 2001 Electra glide speedo problems

check the vehicle speed sensor for metal on the magnet.&nbsp\\; it's easy to get to on the top of the transmission.&nbsp\\; If you have trouble with your turn signals not self canceling it's for sure it's the sensor.&nbsp\\; About $60.
Reply With Quote
  #5  
Old 09-21-2010, 02:31 AM
erphelps's Avatar
erphelps erphelps is offline
Hang Around
Join Date: Jul 2008
Location: Cincinnati
Posts: 10
Default 2000 Electra Glide

I have the same issue with my 2000. The sensor was replaced and it did not solve it. They took the fairing off and the connection was lose. A year later and I have the same problem again. Also to remove the fairing remove the three screws were the windshiled goes into the fairing and then on the riders side about half way down thier is similar screw on each side.
__________________
2000 Electra Glide Classic 95" Big Bore Kit all Stage II Never been dyno tested and I don't care all I know is for a big bike ten years old it runs like I stold it. Yea that's my son on the back not some bimbo. Gets his sportster in three more years. He loves the bagger but not on dads dime.
Reply With Quote
Old 09-21-2010, 02:31 AM
 
 
 
P
Reply

Tags
2000, 2001, bouncing, disassemble, dyna, electra, glide, harley, module, number, part, road, sensor, speed, speedo, speedometer


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 01:05 PM.


Internet Brands, Inc.



Search Engine Optimization by vBSEO 3.6.1