Go Back   Harley Davidson Forums > Harley Davidson Motorcycles > Touring Models
Sign in using an external account
Register Forgot Password?
Search

Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by: Fuel Moto USA

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 07-15-2011, 02:29 PM
Bearcat1's Avatar
Bearcat1 Bearcat1 is offline
Senior Rider
Join Date: Jan 2008
Location: League City, TX
Posts: 385
Default LED tail light and signal conversion??

I recently installed the HD LED tail light along with the conversion kit that turns rear signals into red brake lights. Looks great but now there is about about a 3 second delay in my turn signal brake lights going back to just tail light shining compared to the LED main brake light when I release brakes. Main LED brake light goes back instantly then few seconds later the signals go back. Can someone tell me if a load equalizer will correct this and get the turn signal lamps and main LED tail lamp changing back at same time? Turn signals bulbs are still standard bulbs. Just main tail lamp is LED. I've read where the load equalizer will correct problems for actually changing your turn signals bulbs to LED's but not so sure this is the same problem since the main tail lamp is involved too. Any electronic whizzes out there?

Thanks
__________________
2014 FLHXS
Reply With Quote
  #2  
Old 07-15-2011, 03:38 PM
Demolitionman Demolitionman is offline
One Of The Regulars
Join Date: Jan 2011
Location: Greer, SC
Posts: 254
Demolitionman63
Default

it should not be the problem. if it was, the turn signals should be blinking fast as if they were LED without a load equalizer. not sure what the problem might be though.
Reply With Quote
  #3  
Old 07-15-2011, 03:45 PM
IAMSWUTIAMS's Avatar
IAMSWUTIAMS IAMSWUTIAMS is offline
Extreme HDF Member
Join Date: Nov 2006
Location: San Diego, Mexifornia
Posts: 18,610
Socialist poopoo Is for twits I don't remember
Send a message via ICQ to IAMSWUTIAMS Send a message via Yahoo to IAMSWUTIAMS
Default

I don't believe the "kit" needs an equalizer.
Reply With Quote
  #4  
Old 07-15-2011, 04:01 PM
Bearcat1's Avatar
Bearcat1 Bearcat1 is offline
Senior Rider
Join Date: Jan 2008
Location: League City, TX
Posts: 385
Default

Quote:
Originally Posted by Demolitionman View Post
it should not be the problem. if it was, the turn signals should be blinking fast as if they were LED without a load equalizer. not sure what the problem might be though.
Blinking is normal. Only a delay in the turn signals changing back compared to the LED tail light. Definitely has something to do with the LED tail light and the signal conversion interface. Im guessing either one would work fine without the other and nothing additional would be needed to work correctly. Surely somebody out there has this setup??
__________________
2014 FLHXS
Reply With Quote
  #5  
Old 07-15-2011, 04:04 PM
wheel752's Avatar
wheel752 wheel752 is offline
Road Captain
Join Date: Jul 2010
Location: Newport, Wa
Posts: 674
Default

Talk to badlands... out of nevada... they know it all
__________________


2000 heritage classic...HQ 103, SE 6 speed
174,000 miles on the clock
Reply With Quote
  #6  
Old 07-16-2011, 06:45 AM
dansflhti dansflhti is online now
Outstanding HDF Member
Join Date: Feb 2007
Location: Nova Scotia
Posts: 2,396
Default

If it was me I'd get rid of the Run/Brake/Turn module and install the HD LED Turnsignals.I'm very happy with the operation and intensity of them.
Reply With Quote
  #7  
Old 07-16-2011, 09:40 AM
Harleypingman's Avatar
Harleypingman Harleypingman is offline
Extreme HDF Member
Join Date: Apr 2006
Location: Roswell, GA
Posts: 10,378
Default

Did you have the RTB on the bike before the HD LED tail light? If so, did everything operate properly?

I'd suspect the problem is the RTB module or LED tail light. I have the BAL-1R tail light w/ the HD RTB module and everything works fine.

You could check the bulb sockets for corrosion; clean them up; add some dilectric grease; and see if that helps.

Hope you find your problem.

Carl
__________________

CMA, Crossties Chapter (GA)
IBA 26580
'04 FLHTPX
Reply With Quote
  #8  
Old 07-16-2011, 12:45 PM
Bearcat1's Avatar
Bearcat1 Bearcat1 is offline
Senior Rider
Join Date: Jan 2008
Location: League City, TX
Posts: 385
Default

Quote:
Originally Posted by Harleypingman View Post
Did you have the RTB on the bike before the HD LED tail light? If so, did everything operate properly?

I'd suspect the problem is the RTB module or LED tail light. I have the BAL-1R tail light w/ the HD RTB module and everything works fine.

You could check the bulb sockets for corrosion; clean them up; add some dilectric grease; and see if that helps.

Hope you find your problem.

Carl
I installed the RTB first with the stock tail light and it worked fine. Few weeks later I installed the LED Tail light. That's when I first noticed it. All the bulb sockets are good as I checked and regreased them when I installed the RTB module. I'll keep digging.
__________________
2014 FLHXS
Reply With Quote
  #9  
Old 04-27-2013, 10:49 AM
GMPSKI GMPSKI is offline
Hang Around
Join Date: Apr 2013
Location: Michigan
Posts: 2
Default

Was this issue resolved? I have the exact same condition and problem. I did some testing and found that the problem is only evident when the led tail light is added.
Reply With Quote
Old 04-27-2013, 10:49 AM
 
 
 
P
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
LED lighting problem....... kilrain Softail Models 9 12-09-2012 06:57 PM
Help Spiro Drummer Dyna Glide Models 3 07-28-2011 01:18 AM
LED tail light bulb doesn't work? av8or Softail Models 1 06-13-2010 02:06 AM
LED Turn Signal Problem jetspeed8 General Topics/Tech Tips 3 12-06-2009 04:31 PM
Rear Turning Lamp Question russl179 Sportster Models 11 07-30-2006 03:40 PM


Tags
brake, clasic, conversion, davidson, delay, harley, led, light, lights, minutes, models, motorcycle, motorcycles, signal, tail, touring, turn, ultra


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Join HDForums

Advertising
Featured Sponsors
Vendor Directory
Sponsors

All times are GMT -5. The time now is 07:25 PM.


© Internet Brands, Inc.