cruise control not working - Harley Davidson Forums



Touring Models Road King, Road King Custom, Road King Classic, Road Glide, Street Glide, Electra Glide, Electra Glide Classic, and Electra Glide Ultra Classic bikes.
Sponsored by:
Sponsored by:

cruise control not working

Reply
 
 
 
P
 
Thread Tools Search this Thread
  #1  
Old 06-26-2011, 07:11 PM
jgann jgann is offline
New Member
Thread Starter
Join Date: May 2011
Location: Myrtle Beach
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default cruise control not working

2002 ultra cruise control not working. the light comes on when you flip the switch, but cruise does not engage. What can I check?
Reply With Quote
  #2  
Old 06-26-2011, 07:27 PM
07DDreamHD's Avatar
07DDreamHD 07DDreamHD is offline
One Of The Regulars
Join Date: May 2009
Location: Bastrop, LA
Posts: 263
Thanks: 0
Thanked 1 Time in 1 Post
Default

The cruise control is very sensitive. Sometimes it may be the connections and sometimes it may require that you go through the set-up procedures that are listed in your manual. Maybe try to go back through the set-up in the manual. If that does not fix the problem, then check your connections.
Reply With Quote
  #3  
Old 06-26-2011, 07:31 PM
Lito Lito is offline
New Member
Join Date: Jun 2011
Location: Gilbert
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem. I have checked anything yet let me know what you find out. I have a 2002 rk classic thanks
Reply With Quote
  #4  
Old 06-26-2011, 07:34 PM
Stiggy's Avatar
Stiggy Stiggy is offline
Ultimate HDF Member
Join Date: Nov 2010
Location: Oxford, Nc
Posts: 9,878
Thanked 247 Times in 184 Posts
Default

Could be as simple as a broken/frayed control cable. I lost one on my 98 Ultra.
Reply With Quote
  #5  
Old 06-26-2011, 07:36 PM
Lito Lito is offline
New Member
Join Date: Jun 2011
Location: Gilbert
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a 2002 rk classic with 95 big boar kit, 2 into1 thunder header with power commander. Getting ready to install cams and either doing new hydraulic or gear. Any good or bad info to help me make my mind up. 510 cams is what i was thinking
Reply With Quote
  #6  
Old 06-26-2011, 07:37 PM
hd4evr2008's Avatar
hd4evr2008 hd4evr2008 is online now
Outstanding HDF Member
Join Date: Jun 2008
Location: Ohio
Posts: 2,107
Thanked 243 Times in 158 Posts
Default

Reply With Quote
  #7  
Old 06-26-2011, 07:38 PM
Neil's Avatar
Neil Neil is offline
Road Captain
Join Date: Jun 2006
Location: Cape Cod, Ma.
Posts: 575
Thanks: 0
Thanked 10 Times in 9 Posts
Default

I'm having the same problem with my 02. 07DDreamHD, jgann and I have cable operated throtles. I don't think there is any re-set procedure that I have found. If anyone knows of something I would love to hear it. My prblems started after I installed braided brake lines. The switch lights up, the fuse is good but no cruise (no green "C" on the dash). The brake lights work as they are supposed to when the the brakes are applied. Any thoughts?

Neil
RDMC
Reply With Quote
  #8  
Old 06-26-2011, 07:39 PM
vickers1's Avatar
vickers1 vickers1 is offline
Road Warrior
Join Date: Jun 2006
Location: Southeast GA
Posts: 1,948
Thanks: 0
Thanked 1 Time in 1 Post
Default

Follow your throttle cable from the handlebars. You'll find a switch. Unplug one wire from the switch. Ride the bike and check the cruise. If it works, replace the switch.
Reply With Quote
  #9  
Old 06-26-2011, 08:12 PM
07custom's Avatar
07custom 07custom is offline
One Of The Regulars
Join Date: Aug 2007
Location: 40 mi South of Pittsburgh
Posts: 126
Thanked 2 Times in 1 Post
Default

Is the rear brake light lit all the time? My rear brake switch went, cruise didn't work & the brake light stayed on all the time.
Reply With Quote
  #10  
Old 06-27-2011, 01:37 AM
Potato_Potato's Avatar
Potato_Potato Potato_Potato is offline
Outstanding HDF Member
Join Date: Sep 2005
Location: Minnesota
Posts: 2,599
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Check both brake light switches.
Reply With Quote
 
 
 
P
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
cruise control STONER63 Primary/Transmission/Driveline/Clutch 3 08-02-2017 05:37 PM
cruise control quit mlbmd Touring Models 10 05-20-2017 09:32 PM
Dash Lights Ultradickweed Touring Models 9 09-05-2016 04:49 PM
Cruise control for 1986 Electra Brew-Daddy Ignition/Tuner/ECM/Fuel Injection 0 02-15-2014 01:26 PM
cruise control problem kileygruben Touring Models 9 07-21-2010 10:16 PM


Tags
2002, classic, contro, control, cruise, cruze, davidson, fuse, harley, problem, problems, quit, touring, ultra, work, working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Featured Sponsors
Vendor Directory

All times are GMT -5. The time now is 10:23 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: